hdu1002 ,大数相加,一点都不难,嘿嘿嘿

I have a very simple problem for you. Given two integers A and B, your job is to calculate the Sum of A + B. 

Input

The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line consists of two positive integers, A and B. Notice that the integers are very large, that means you should not process them by using 32-bit integer. You may assume the length of each integer will not exceed 1000. 

Output

For each test case, you should output two lines. The first line is "Case #:", # means the number of the test case. The second line is the an equation "A + B = Sum", Sum means the result of A + B. Note there are some spaces int the equation. Output a blank line between two test cases. 

Sample Input

2

1 2

112233445566778899  998877665544332211

Sample Output

Case 1:
1 + 2 = 3

Case 2:
112233445566778899 + 998877665544332211 = 1111111111111111110

上代码

#include<iostream>
#include<string.h>
using namespace std;
char a[1001],b[1001];
int n1[1001],n2[1001];
int main()
{	
	int x,w=0;
	cin>>x;
	while(x--)
	{
	int l1,l2,i,j,max;
    for(int l=0;l<1001;l++) 
	{
		n1[l]=0;
		n2[l]=0;
	}
 	cin>>a>>b;
    l1=strlen(a);
    l2=strlen(b);
    if(l1>l2)max=l1;
    else max=l2;
    for(i=l1-1,j=0; i>=0 ;i--)
        {
            n1[j]=a[i]-48;
            j++;
        }
    for(i=l2-1,j=0; i>=0 ;i--)
      {
        n2[i]=b[j]-48;
        j++;
      }
    for(i=0;i<max;i++)
       {
           n1[i]=n1[i]+n2[i];
           if(n1[i]>9)
           {
               n1[i+1]=n1[i+1]+1;
               n1[i]=n1[i]-10;
           }
       }
       w++;
       cout<<"Case "<<w<<":"<<endl;
       cout<<a<<" + "<<b<<" = ";
       if(n1[i])
        for(j=i;j>-1;j--)
        cout<<n1[j];
       else for(j=i-1;j>-1;j--)
        cout<<n1[j];
        cout<<endl;
        if(x)
        cout<<endl;
	}
        return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值