1472:【例题2】The XOR Largest Pair

1472:【例题2】The XOR Largest Pair

时间限制: 1000 ms 内存限制: 65536 KB
提交数: 644 通过数: 304
【题目描述】
在给定的 N 个整数 A1,A2,…,AN 中选出两个进行异或运算,得到的结果最大是多少?

【输入】
第一行一个整数 N。

第二行 N 个整数 Ai​​ 。

【输出】
一个整数表示答案。

【输入样例】
5
2 9 5 7 0
【输出样例】
14
【提示】
对于 100% 的数据,1≤N≤105,0≤Ai<231​​ 。

#include <bits/stdc++.h>

using namespace std;
const int N=4e6+5;
int tree[N][2],cnt=0,n,x;

void Insert()//高位到低位
{
    int now=0;
    for(int i=30;i>=0;i--)//固定31位
    {
        int y=x>>i&1;
        if(tree[now][y]==0)
            tree[now][y]=++cnt;
        now=tree[now][y];
    }
}
int Find()
{
    int now=0,ans=0;
    for(int i=30;i>=0;i--)
    {
        int y=x>>i&1;
        if(tree[now][!y])
        {
            ans+=1<<i;
            now=tree[now][!y];
        }
        else
            now=tree[now][y];
    }
    return ans;
}
int main()
{
    ios::sync_with_stdio(false);
    cin.tie(0);
    cout.tie(0);
    cin >> n;
    int res=0;
    while(n--)
    {
        cin >> x;
        Insert();
        res=max(res,Find());
    }
    cout << res << endl;
    return 0;
}

  • 1
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值