HDU1542 Atlantis ( 线段树求矩形面积并)

Atlantis
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 26563 Accepted Submission(s): 10479

Problem Description
There are several ancient Greek texts that contain descriptions of the fabled island Atlantis. Some of these texts even include maps of parts of the island. But unfortunately, these maps describe different regions of Atlantis. Your friend Bill has to know the total area for which maps exist. You (unwisely) volunteered to write a program that calculates this quantity.

Input
The input file consists of several test cases. Each test case starts with a line containing a single integer n (1<=n<=100) of available maps. The n following lines describe one map each. Each of these lines contains four numbers x1;y1;x2;y2 (0<=x1<x2<=100000;0<=y1<y2<=100000), not necessarily integers. The values (x1; y1) and (x2;y2) are the coordinates of the top-left resp. bottom-right corner of the mapped area.

The input file is terminated by a line containing a single 0. Don’t process it.

Output
For each test case, your program should output one section. The first line of each section must be “Test case #k”, where k is the number of the test case (starting with 1). The second one must be “Total explored area: a”, where a is the total explored area (i.e. the area of the union of all rectangles in this test case), printed exact to two digits to the right of the decimal point.

Output a blank line after each test case.

Sample Input
2
10 10 20 20
15 15 25 25.5
0

Sample Output
Test case #1
Total explored area: 180.00

#include <iostream>
#include <cstdio>
#include <cstring>
#include <string>
#include <algorithm>
#include <vector>
#include <stack>

using namespace std;
/*
一层一层加
*/
const int N=1e2+5;
struct edge
{
    double x1,x2,y;
    int sta;
    //edge(){}
    //edge(double x1,double x2,double y,int sta):x1(x1),x2(x2),y(y),sta(sta){}
    bool operator<(const edge &t)const
    {
        return y<t.y;
    }
} a[N<<1]; //存线
double x1,y1,x2,y2;
double tree[N<<3];//长度(宽度)
int lazy[N<<3];//边的数量
double b[N<<1];//x坐标
int n;

//对x轴区间建树
void push_up(int id,int l,int r)
{
    if(lazy[id])
        tree[id]=b[r+1]-b[l];
    else if(l==r)//一个点,没有长度
        tree[id]=0;
    else
        tree[id]=tree[id<<1]+tree[id<<1|1];
}
void update(int id,int l,int r,int x,int y,int sta)
{
    if(x<=l&&r<=y)
    {
        lazy[id]+=sta;
        push_up(id,l,r);
        return;
    }
    int mid=(l+r)>>1;
    if(x<=mid)
        update(id*2,l,mid,x,y,sta);
    if(y>=mid+1)
        update(id*2+1,mid+1,r,x,y,sta);
    push_up(id,l,r);
}
int main()
{
    int k=0;
    while(cin >> n,n)
    {
        for(int i=1; i<=n; i++)
        {
            cin >> x1 >> y1 >> x2 >> y2;
            //scanf("%lf%lf%lf%lf",&x1,&y1,&x2,&y2);
            //先1再-1
            a[i]= {x1,x2,y1,1};
            a[i+n]= {x1,x2,y2,-1};
            b[i]=x1;
            b[i+n]=x2;
        }
        n<<=1;
        sort(a+1,a+n+1);
        sort(b+1,b+n+1);
        int m=unique(b+1,b+n+1)-b-1;//不重复的个数
        double res=0;
        memset(tree,0,sizeof(tree));
        memset(lazy,0,sizeof(lazy));
        for(int i=1; i<n; i++)//循环n-1次,算高度差
        {
            //l r都是下标
            int l=lower_bound(b+1,b+m+1,a[i].x1)-b;
            int r=lower_bound(b+1,b+m+1,a[i].x2)-b;
            if(l<r)
                update(1,1,m,l,r-1,a[i].sta);//注意r-1,一个数表示一条单位边的位置
            //printf("宽%.2f*高%.2f=%.2f\n",tree[1],(a[i+1].y-a[i].y),tree[1]*(a[i+1].y-a[i].y));
            res+=tree[1]*(a[i+1].y-a[i].y);
        }
        printf("Test case #%d\nTotal explored area: %.2f\n\n",++k,res);
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
站用交流系统断路器保护灵敏度校验整改及剩余电流监测试点应用站用交流系统断路器保护灵敏度校验整改及剩余电流监测试点应用站用交流系统断路器保护灵敏度校验整改及剩余电流监测试点应用站用交流系统断路器保护灵敏度校验整改及剩余电流监测试点应用站用交流系统断路器保护灵敏度校验整改及剩余电流监测试点应用站用交流系统断路器保护灵敏度校验整改及剩余电流监测试点应用站用交流系统断路器保护灵敏度校验整改及剩余电流监测试点应用站用交流系统断路器保护灵敏度校验整改及剩余电流监测试点应用站用交流系统断路器保护灵敏度校验整改及剩余电流监测试点应用站用交流系统断路器保护灵敏度校验整改及剩余电流监测试点应用站用交流系统断路器保护灵敏度校验整改及剩余电流监测试点应用站用交流系统断路器保护灵敏度校验整改及剩余电流监测试点应用站用交流系统断路器保护灵敏度校验整改及剩余电流监测试点应用站用交流系统断路器保护灵敏度校验整改及剩余电流监测试点应用站用交流系统断路器保护灵敏度校验整改及剩余电流监测试点应用站用交流系统断路器保护灵敏度校验整改及剩余电流监测试点应用站用交流系统断路器保护灵敏度校验整改及剩余电流监测试点应用站用交流系统断

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值