HDU 1542 Atlantis 线段树 扫描线 离散化

115 篇文章 0 订阅
7 篇文章 0 订阅

Atlantis

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 8998    Accepted Submission(s): 3856


Problem Description
There are several ancient Greek texts that contain descriptions of the fabled island Atlantis. Some of these texts even include maps of parts of the island. But unfortunately, these maps describe different regions of Atlantis. Your friend Bill has to know the total area for which maps exist. You (unwisely) volunteered to write a program that calculates this quantity.
 

Input
The input file consists of several test cases. Each test case starts with a line containing a single integer n (1<=n<=100) of available maps. The n following lines describe one map each. Each of these lines contains four numbers x1;y1;x2;y2 (0<=x1<x2<=100000;0<=y1<y2<=100000), not necessarily integers. The values (x1; y1) and (x2;y2) are the coordinates of the top-left resp. bottom-right corner of the mapped area.

The input file is terminated by a line containing a single 0. Don’t process it.
 

Output
For each test case, your program should output one section. The first line of each section must be “Test case #k”, where k is the number of the test case (starting with 1). The second one must be “Total explored area: a”, where a is the total explored area (i.e. the area of the union of all rectangles in this test case), printed exact to two digits to the right of the decimal point.

Output a blank line after each test case.
 

Sample Input
 
 
2 10 10 20 20 15 15 25 25.5 0
 

Sample Output
 
 

Test case #1 

Total explored area: 180.00

看了胡浩的线段树敲的

我改了一点地方就是我自己好理解 改的地方是把点树变成了区间树

所以更新的时候需要改变

我取的是两个闭区间

点击打开链接

#include <cstdio>
#include <cstring>
#include <cctype>
#include <algorithm>
using namespace std;
#define lson l , m , rt << 1
#define rson m , r , rt << 1 | 1

const int maxn = 2222;
int cnt[maxn << 2];
double sum[maxn << 2];
double X[maxn];
struct Seg {
       double h , l , r;
       int s;
       Seg(){}
       Seg(double a,double b,double c,int d) : l(a) , r(b) , h(c) , s(d) {}
       bool operator < (const Seg &cmp) const {
              return h < cmp.h;
       }
}ss[maxn];
void PushUp(int rt,int l,int r) {
       if (cnt[rt]) sum[rt] = X[r] - X[l];
       else if (l == r) sum[rt] = 0;
       else sum[rt] = sum[rt<<1] + sum[rt<<1|1];
}
void update(int L,int R,int c,int l,int r,int rt) {
       if (L <= l && r <= R) {
              cnt[rt] += c;
              PushUp(rt , l , r);
              return ;
       }
       int m = (l + r) >> 1;
       if (L < m) update(L , R , c , lson);//注意一定不能等于 因为我这里是两个闭区间
       if (m < R) update(L , R , c , rson);
       PushUp(rt , l , r);
}
int Bin(double key,int n,double X[]) {
       int l = 0 , r = n - 1;
       while (l <= r) {
              int m = (l + r) >> 1;
              if (X[m] == key) return m;
              if (X[m] < key) l = m + 1;
              else r = m - 1;
       }
       return -1;
}
int main() {
       int n , cas = 1;
       while (~scanf("%d",&n) && n) {
              int m = 0;
              while (n --) {
                     double a , b , c , d;
                     scanf("%lf%lf%lf%lf",&a,&b,&c,&d);
                     X[m] = a;
                     ss[m++] = Seg(a , c , b , 1);
                     X[m] = c;
                     ss[m++] = Seg(a , c , d , -1);
              }
              sort(X , X + m);
              sort(ss , ss + m);
              int k = 1;
              for (int i = 1 ; i < m ; i ++) {
                     if (X[i] != X[i-1]) X[k++] = X[i];
              }
              memset(cnt , 0 , sizeof(cnt));
              memset(sum , 0 , sizeof(sum));
              double ret = 0;
              for (int i = 0 ; i < m - 1 ; i ++) {
                     int l = Bin(ss[i].l , k , X);
                     int r = Bin(ss[i].r , k , X);
                     if (l <= r) update(l , r , ss[i].s , 0 , k - 1, 1);
                     ret += sum[1] * (ss[i+1].h - ss[i].h);
              }
              printf("Test case #%d\nTotal explored area: %.2lf\n\n",cas++ , ret);
       }
       return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
提供的源码资源涵盖了安卓应用、小程序、Python应用和Java应用等多个领域,每个领域都包含了丰富的实例和项目。这些源码都是基于各自平台的最新技术和标准编写,确保了在对应环境下能够无缝运行。同时,源码中配备了详细的注释和文档,帮助用户快速理解代码结构和实现逻辑。 适用人群: 这些源码资源特别适合大学生群体。无论你是计算机相关专业的学生,还是对其他领域编程感兴趣的学生,这些资源都能为你提供宝贵的学习和实践机会。通过学习和运行这些源码,你可以掌握各平台开发的基础知识,提升编程能力和项目实战经验。 使用场景及目标: 在学习阶段,你可以利用这些源码资源进行课程实践、课外项目或毕业设计。通过分析和运行源码,你将深入了解各平台开发的技术细节和最佳实践,逐步培养起自己的项目开发和问题解决能力。此外,在求职或创业过程中,具备跨平台开发能力的大学生将更具竞争力。 其他说明: 为了确保源码资源的可运行性和易用性,特别注意了以下几点:首先,每份源码都提供了详细的运行环境和依赖说明,确保用户能够轻松搭建起开发环境;其次,源码中的注释和文档都非常完善,方便用户快速上手和理解代码;最后,我会定期更新这些源码资源,以适应各平台技术的最新发展和市场需求。

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值