PAT-1094-树的遍历

A family hierarchy is usually presented by a pedigree tree where all the nodes on the same level belong to the same generation. Your task is to find the generation with the largest population.

Input Specification:

Each input file contains one test case. Each case starts with two positive integers N (<100) which is the total number of family members in the tree (and hence assume that all the members are numbered from 01 to N), and M (<N) which is the number of family members who have children. Then M lines follow, each contains the information of a family member in the following format:

ID K ID[1] ID[2] … ID[K]

where ID is a two-digit number representing a family member, K (>0) is the number of his/her children, followed by a sequence of two-digit ID’s of his/her children. For the sake of simplicity, let us fix the root ID to be 01. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print in one line the largest population number and the level of the corresponding generation. It is assumed that such a generation is unique, and the root level is defined to be 1.

Sample Input:

23 13
21 1 23
01 4 03 02 04 05
03 3 06 07 08
06 2 12 13
13 1 21
08 2 15 16
02 2 09 10
11 2 19 20
17 1 22
05 1 11
07 1 14
09 1 17
10 1 18

Sample Output:

9 4

谷歌中文翻译:

家庭层次结构通常由谱系树表示,其中同一级别上的所有节点都属于同一世代。您的任务是找到人口最多的世代。

输入规格:

每个输入文件包含一个测试用例。每种情况都以两个正整数N(<100)开头,N是树中家庭成员的总数(因此,假定所有成员的编号都从01到N进行编号),而M(<N)则是两个正整数。有孩子的家庭成员。然后是M行,每行包含以下格式的家庭成员信息:

ID K ID [1] ID [2]…ID [K]

其中ID是代表家庭成员的两位数字,K(> 0)是他/她的孩子的数目,后跟他/她的孩子的两位数字ID的序列。为了简单起见,让我们将根ID固定为01。一行中的所有数字都用空格分隔。

输出规格:

对于每个测试用例,在一行中打印最大的人口数量和相应代的级别。假定这样的世代是唯一的,并且根级别定义为1。

思路:
要求的是结点最多的那层和结点数,深搜遍历拿一个数组记录每层的结点数就行。

#include<bits/stdc++.h>
using namespace std;

const int MAX_N = 510;

int n, m;
int book[MAX_N];
vector<int> v[MAX_N];

void init() {
	cin >> n >> m;
	int t, k;
	for(int i = 0; i < m; i++) {
		cin >> t >> k;
		for(int j = 0; j < k; j++) {
			int temp;
			cin >> temp;
			v[t].push_back(temp);
		}
	} 
} 

void dfs(int index, int depth) {
	book[depth]++;
	for(int i = 0; i < v[index].size(); i++) {
		dfs(v[index][i], depth + 1);
	}
}

int main() {
	init();
	dfs(1, 1);
	int maxnum = 0, maxlevel = 1;
    for(int i = 1; i < 100; i++) {
        if(book[i] > maxnum) {
            maxnum = book[i];
            maxlevel = i;
        }
    }
    cout << maxnum << " " << maxlevel;
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值