Bee(UVA11000)

Description

In Africa there is a very special species of bee. Every year, the female bees of such species give birthto one male bee, while the male bees give birth to one male bee and one female bee, and then they die!

Now scientists have accidentally found one “magical female bee” of such special species to the effectthat she is immortal, but still able to give birth once a year as all the other female bees. The scientistswould like to know how many bees there will be after N years. Please write a program that helps themfind the number of male bees and the total number of all bees after N years.

Input

Each line of input contains an integer N (≥ 0). Input ends with a case where N = −1. (This caseshould NOT be processed.)

Output

Each line of output should have two numbers, the first one being the number of male bees after Nyears, and the second one being the total number of bees after N years. (The two numbers will notexceed 2^32.)

Sample Input

1

3

-1

Sample Output

1 2

4 7

思路

这就是一个简单的递归问题
雌蜂的数量是上一年雄蜂的数量+1,雄蜂的数量是上一年的总数。

AC代码

#include<iostream>
using namespace std;
int main(){
long long int f,m ,a;//雌蜂的数量,雄峰的数量,总数量
long long int n;
while(cin>>n&&n!=-1){
        f=1,m = 0,a=0;
    for(long long int i = 0;i<=n;i++){
        f = m+1;
        m = a;
        a = f+m;
    }
    cout<<m<<" "<<a<<endl;
}
return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值