1007 Maximum Subsequence Sum(DP)

题目描述

Given a sequence of K integers { N1, N2, …, NK}. A continuous subsequence is defined to be { Ni, N​i+1, …, Nj} where 1≤i≤j≤K. The Maximum Subsequence is the continuous subsequence which has the largest sum of its elements. For example, given sequence { -2, 11, -4, 13, -5, -2 }, its maximum subsequence is { 11, -4, 13 } with the largest sum being 20.
Now you are supposed to find the largest sum, together with the first and the last numbers of the maximum subsequence.

输入格式

Each input file contains one test case. Each case occupies two lines. The first line contains a positive integer K (≤10000). The second line contains K numbers, separated by a space.#

输出格式

For each test case, output in one line the largest sum, together with the first and the last numbers of the maximum subsequence. The numbers must be separated by one space, but there must be no extra space at the end of a line. In case that the maximum subsequence is not unique, output the one with the smallest indices i and j (as shown by the sample case). If all the K numbers are negative, then its maximum sum is defined to be 0, and you are supposed to output the first and the last numbers of the whole sequence.

输入样例

10
-10 1 2 3 4 -5 -23 3 7 -21

输出样例

10 1 4

题目大意

给出一段序列,求最大连续子序列和,以及起始元素和末尾元素。1.若最大序列不止一个,则输出索引最小的。 2.若整个序列皆为负数,则最大和为0,输出整个序列的起始元素和末尾元素。

思路

简单的动态规划问题。注意起始元素start和末尾元素end要初始化为A[0],否则特殊情况1无法满足。

AC代码

#include <iostream>
using namespace std;

const int maxn = 10010;
int k, A[maxn], dp[maxn], s[maxn];
//s[i]存放dp[i]对应的起始元素 

int main(){
	cin>>k;
	int start, end, sum;
	for(int i = 0; i < k; i++)
		cin>>A[i];
	dp[0] = A[0], s[0] = A[0];
	start = A[0], end = A[0], sum = A[0];
	for(int i = 1; i < k; i++){
		if(dp[i - 1] > 0){
			dp[i] = dp[i - 1] + A[i];
			s[i] = s[i - 1];
		}
		else{
			s[i] = A[i];
			dp[i] = A[i];
		}
		if(sum < dp[i]){
			sum = dp[i];
			start = s[i], end = A[i];
		}
	}
	//但凡序列里有一个非负数,sum都不会为负数
	if(sum < 0) cout<<"0 "<<A[0]<<" "<<A[k - 1];
	else cout<<sum<<" "<<start<<" "<<end;
	return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值