Eva is trying to make her own color stripe out of a given one. She would like to keep only her favorite colors in her favorite order by cutting off those unwanted pieces and sewing the remaining parts together to form her favorite color stripe.
It is said that a normal human eye can distinguish about less than 200 different colors, so Eva’s favorite colors are limited. However the original stripe could be very long, and Eva would like to have the remaining favorite stripe with the maximum length. So she needs your help to find her the best result.
Note that the solution might not be unique, but you only have to tell her the maximum length. For example, given a stripe of colors {2 2 4 1 5 5 6 3 1 1 5 6}. If Eva’s favorite colors are given in her favorite order as {2 3 1 5 6}, then she has 4 possible best solutions {2 2 1 1 1 5 6}, {2 2 1 5 5 5 6}, {2 2 1 5 5 6 6}, and {2 2 3 1 1 5 6}.
Input Specification:
Each input file contains one test case. For each case, the first line contains a positive integer N (≤200) which is the total number of colors involved (and hence the colors are numbered from 1 to N). Then the next line starts with a positive integer M (≤200) followed by M Eva’s favorite color numbers given in her favorite order. Finally the third line starts with a positive integer L (≤10
4
) which is the length of the given stripe, followed by L colors on the stripe. All the numbers in a line a separated by a space.
Output Specification:
For each test case, simply print in a line the maximum length of Eva’s favorite stripe.
Sample Input:
6
5 2 3 1 5 6
12 2 2 4 1 5 5 6 3 1 1 5 6
Sample Output:
7
题目大意及思路
求两个序列的最长公共子序列,但序列B中可存在重复值,只需顺序与A中一致即可。因此,可采用动态规划的方法,设dp[i][j]为A中第i个元素之前和B中第j个元素之前的最长公共子序列长度,状态转移方程见代码。
AC代码
#include <cstdio>
#include <algorithm>
using namespace std;
int n,m,l;
int A[201], B[10001];
int dp[201][10001];
int main(){
int n, m, l;
fill(dp[0], dp[0] + 201 * 10001, 0);
scanf("%d%d", &n, &m);
for(int i = 1; i <= m; i++)
scanf("%d", &A[i]);
scanf("%d", &l);
for(int j = 1; j <= l; j++)
scanf("%d", &B[j]);
for(int i = 1; i <= m; i++){
for(int j = 1; j <= l; j++){
//状态转移方程
if(A[i] == B[j])
dp[i][j] = max(dp[i - 1][j], dp[i][j - 1] + 1);
else dp[i][j] = max(dp[i - 1][j], dp[i][j - 1]);
}
}
printf("%d", dp[m][l]);
return 0;
}