A Binary Search Tree (BST) is recursively defined as a binary tree which has the following properties:
The left subtree of a node contains only nodes with keys less than or equal to the node’s key.
The right subtree of a node contains only nodes with keys greater than the node’s key.
Both the left and right subtrees must also be binary search trees.
Insert a sequence of numbers into an initially empty binary search tree. Then you are supposed to count the total number of nodes in the lowest 2 levels of the resulting tree.
Input Specification:
Each input file contains one test case. For each case, the first line gives a positive integer N (≤1000) which is the size of the input sequence. Then given in the next line are the N integers in [−1000,1000] which are supposed to be inserted into an initially empty binary search tree.
Output Specification:
For each case, print in one line the numbers of nodes in the lowest 2 levels of the resulting tree in the format:
n1 + n2 = n
where n1 is the number of nodes in the lowest level, n2 is that of the level above, and n is the sum.
Sample Input:
9
25 30 42 16 20 20 35 -5 28
Sample Output:
2 + 4 = 6
AC代码
#include <iostream>
using namespace std;
typedef struct node{
int data;
node *lchild, *rchild;
}*BTree, BNode;
int depth, num[1010] = {0}; //深度 每层结点数
BNode* newNode(int v){
BNode* Node = new node;
Node->data = v;
Node->lchild = NULL;
Node->rchild = NULL;
return Node;
}
void insert(BTree &BT, int x){
if(BT == NULL){
BT = newNode(x);
return;
}
if(x <= BT->data)
insert(BT->lchild, x);
else insert(BT->rchild, x);
}
BTree create(int data[], int n){
BTree BT = NULL;
for(int i = 0; i < n; i++)
insert(BT, data[i]);
return BT;
}
//获得树的深度以及每层的结点数
void getdepth(BTree BT, int level){
if(BT == NULL) return;
if(level > depth) depth = level;
num[level]++;
getdepth(BT->lchild, level + 1);
getdepth(BT->rchild, level + 1);
}
int main(){
int n, data[1010];
cin>>n;
for(int i = 0; i < n; i++)
cin>>data[i];
BTree BT = create(data, n);
getdepth(BT, 0);
int sum = num[depth] + num[depth - 1];
cout<<num[depth]<<" + "<<num[depth - 1]<<" = "<<sum;
return 0;
}