1129 Recommendation System

Recommendation system predicts the preference that a user would give to an item. Now you are asked to program a very simple recommendation system that rates the user’s preference by the number of times that an item has been accessed by this user.

Input Specification:

Each input file contains one test case. For each test case, the first line contains two positive integers: N (≤ 50,000), the total number of queries, and K (≤ 10), the maximum number of recommendations the system must show to the user. Then given in the second line are the indices of items that the user is accessing – for the sake of simplicity, all the items are indexed from 1 to N. All the numbers in a line are separated by a space.

Output Specification:

For each case, process the queries one by one. Output the recommendations for each query in a line in the format:

query: rec[1] rec[2] … rec[K]

where query is the item that the user is accessing, and rec[i] (i=1, … K) is the i-th item that the system recommends to the user. The first K items that have been accessed most frequently are supposed to be recommended in non-increasing order of their frequencies. If there is a tie, the items will be ordered by their indices in increasing order.

Note: there is no output for the first item since it is impossible to give any recommendation at the time. It is guaranteed to have the output for at least one query.

Sample Input:

12 3
3 5 7 5 5 3 2 1 8 3 8 12

Sample Output:

5: 3
7: 3 5
5: 3 5 7
5: 5 3 7
3: 5 3 7
2: 5 3 7
1: 5 3 2
8: 5 3 1
3: 5 3 1
8: 3 5 1
12: 3 5 8

题目大意

依次给出n条顾客访问记录(即每次访问的item编号),要求输出每条访问记录之前(除了第一条),该顾客访问次数最多的m个item。

思路

这一题若是仅仅用vector存储每个item的id和访问次数,然后输入每条记录时将其排序,输出排在前k位的记录,必然会超时(最多50000次遍历,其中vector最大size也为50000…)。因此,我设置了另一个数组vis,以item编号为下标,存储其访问次数。遍历每条记录时先将vis更新,再在vector中找出当前访问的item(若没有则先插入),并将其访问次数num改为vis[id]。并依照题意进行排序。最重要的一点,也是降低复杂度的方法,在于当vector的size大于m时,去除最后一位元素,使vector的size最多不超过m(m<=10)。

AC代码

#include <cstdio>
#include <vector>
#include <iostream>
#include <algorithm> 
using namespace std; 

struct item{
	int id = -1, num = 0; //编号及访问次数 
	item(int a, int b): id(a), num(b){}
};

bool cmp(item a, item b){
	if(a.num != b.num)
		return a.num > b.num;
	else return a.id < b.id;
}

int main(){
	int n, m, id;
	scanf("%d%d", &n, &m);
	vector<item> Rec;
	vector<int> vis(n + 1); //id-访问次数 
	scanf("%d", &id);
	Rec.push_back(item(id, 1));
	vis[id]++;
	for(int i = 1; i < n; i++){		
		scanf("%d", &id);
		vis[id]++;
		printf("%d:", id);
		for(int j = 0; j < Rec.size() && j < m; j++)
			printf(" %d", Rec[j]);
		printf("\n"); 		
		int j = 0;
		while(Rec[j].id != id && j < Rec.size()) j++;
		if(j == Rec.size()) //第一次访问该item	
			Rec.push_back(item(id, 1));
		Rec[j].num = vis[id];
		sort(Rec.begin(), Rec.end(), cmp);
		if(Rec.size() > m)
			Rec.pop_back();
	}
	return 0;
}
  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值