1130 Infix Expression

Given a syntax tree (binary), you are supposed to output the corresponding infix expression, with parentheses reflecting the precedences of the operators.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (≤ 20) which is the total number of nodes in the syntax tree. Then N lines follow, each gives the information of a node (the i-th line corresponds to the i-th node) in the format:

data left_child right_child

where data is a string of no more than 10 characters, left_child and right_child are the indices of this node’s left and right children, respectively. The nodes are indexed from 1 to N. The NULL link is represented by −1. The figures 1 and 2 correspond to the samples 1 and 2, respectively.

infix1.JPG infix2.JPG

Output Specification:

For each case, print in a line the infix expression, with parentheses reflecting the precedences of the operators. Note that there must be no extra parentheses for the final expression, as is shown by the samples. There must be no space between any symbols.

Sample Input 1:

8
* 8 7
a -1 -1
* 4 1
+ 2 5
b -1 -1
d -1 -1
- -1 6
c -1 -1

Sample Output 1:

(a+b)*(c*(-d))

Sample Input 2:

8
2.35 -1 -1
* 6 1
- -1 4
% 7 8
+ 2 3
a -1 -1
str -1 -1
871 -1 -1

Sample Output 2:

(a*2.35)+(-(str%871))

题目大意及思路

根据一个二叉树所表示的代数式,输出相应的中缀表达式。
这题基本思路是中序遍历,重点在于括号的输出(好像408考过?)。我们可以从题意得知,对于任意一个子树,要输出括号需满足2个条件:1.该子树不是原树;2.该子树的根结点不为叶子结点。

AC代码

#include <cstdio>
#include <vector>
#include <iostream>
using namespace std; 

struct node{
	string data;
	int lchild, rchild;
}BT[21];
int n, root, hashTable[21] = {0};

 
void infix(int index){
	if(index == -1) return;
	bool flag = false; //该子树是否需要输出括号
	if(index != root && BT[index].rchild != -1)
		flag = true;
	if(flag) cout<<"(";
	infix(BT[index].lchild);
	cout<<BT[index].data;
	infix(BT[index].rchild);
	if(flag) cout<<")";
}

int main(){
	cin>>n;
	for(int i = 1; i <= n; i++){
		cin>>BT[i].data>>BT[i].lchild>>BT[i].rchild;
		hashTable[BT[i].lchild]++;
		hashTable[BT[i].rchild]++;
	}
	for(int i = 1; i <= n; i++){
		if(hashTable[i] == 0){
			root = i;
			break;
		}
	}
	infix(root);
	return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值