1137 Final Grading

For a student taking the online course “Data Structures” on China University MOOC (http://www.icourse163.org/), to be qualified for a certificate, he/she must first obtain no less than 200 points from the online programming assignments, and then receive a final grade no less than 60 out of 100. The final grade is calculated by G=(Gmid−term×40%+Gfinal×60%) if Gmid−term​>Gfinal , or Gfinal will be taken as the final grade G. Here G​mid−term and Gfinal are the student’s scores of the mid-term and the final exams, respectively.

The problem is that different exams have different grading sheets. Your job is to write a program to merge all the grading sheets into one.

Input Specification:

Each input file contains one test case. For each case, the first line gives three positive integers: P , the number of students having done the online programming assignments; M, the number of students on the mid-term list; and N, the number of students on the final exam list. All the numbers are no more than 10,000.

Then three blocks follow. The first block contains P online programming scores G​p’s; the second one contains M mid-term scores Gmid−term’s; and the last one contains N final exam scores G​final’s. Each score occupies a line with the format: StudentID Score, where StudentID is a string of no more than 20 English letters and digits, and Score is a nonnegative integer (the maximum score of the online programming is 900, and that of the mid-term and final exams is 100).

Output Specification:

For each case, print the list of students who are qualified for certificates. Each student occupies a line with the format:

StudentID G​p G​mid−term Gfinal G

If some score does not exist, output “−1” instead. The output must be sorted in descending order of their final grades (G must be rounded up to an integer). If there is a tie, output in ascending order of their StudentID’s. It is guaranteed that the StudentID’s are all distinct, and there is at least one qullified student.

Sample Input:

6 6 7
01234 880
a1903 199
ydjh2 200
wehu8 300
dx86w 220
missing 400
ydhfu77 99
wehu8 55
ydjh2 98
dx86w 88
a1903 86
01234 39
ydhfu77 88
a1903 66
01234 58
wehu8 84
ydjh2 82
missing 99
dx86w 81

Sample Output:

missing 400 -1 99 99
ydjh2 200 98 82 88
dx86w 220 88 81 84
wehu8 300 55 84 84

题目大意

又是乙级原题。成绩录入规则如下:

  • 只有编程成绩大于等于200分、最终成绩在[60, 100]以内的学生才有资格被输出。
  • 若期中成绩>期末成绩,则最终成绩=期中成绩×0.4+期末成绩*0.6,否则最终成绩=期末成绩。

按以上规则计算出同学们的成绩后,将他们按最终成绩排序,若有重复,则再按其ID排序。输出时,若某一项分数不存在,用-1代替。

思路

结构体存储学生的ID和成绩信息。输入时,用map1记录学生的ID和编程作业成绩,map2记录学生的ID和期中成绩。而在输入期末成绩时,先计算学生的最终成绩Gfinal,并根据map1找到该学生的编程成绩,仅将Gfinal>=60、Gprogramming>=200的学生成绩存入vector。判断其是否参加期中考试(由题意,只有期中考试时可能参加也可能未参加的),即该学生ID是否存在于map2中,注意这里不能用gm[stuID]是否大于0来判断(因为map2[stuID]==0的有可能是参加了期末考试但获得0分,最后一个测试点好像就是这样),而应用map2.count(stuID)是否>0。

AC代码

#include <iostream>
#include <algorithm>
#include <string>
#include <vector>
#include <map>
#include <cmath>
using namespace std;

//编程作业分,期中分 
map<string, int> gp, gm;
struct stu{
	string id;
	int Gp = -1, Gm = -1, Gf = -1, G = -1;
};
vector<stu> S;

bool cmp(stu a, stu b){
	if(a.G != b.G)
		return a.G > b.G;
	else
		return a.id < b.id;
}

int main(){
	int p, m, n;
	string a;
	int b;
	cin>>p>>m>>n;
	for(int i = 0; i < p; i++){
		cin>>a>>b;
		if(b <= 900 && b >= 0)
			gp[a] = b;
	}
	for(int i = 0; i < m; i++){
		cin>>a>>b;
		if(b <= 100 && b >= 0)
			gm[a] = b;
	}
	for(int i = 0; i < n; i++){
		cin>>a>>b;
		stu s;
		if(gp[a] >= 200 && b >= 0 && b <= 100){
			s.id = a;
			s.Gp = gp[a];
			if(gm.count(a)>0) //参加了期中考试 
				s.Gm = gm[a];
			s.Gf = b;	
			if(s.Gm > s.Gf)
				s.G = round(s.Gm * 0.4 + s.Gf * 0.6);
			else 
				s.G = s.Gf;
			if(s.G >= 60)									
				S.push_back(s);
		}
	}
	sort(S.begin(), S.end(), cmp);
	for(int i = 0; i < S.size(); i++){
		cout<<S[i].id<<" ";
		cout<<S[i].Gp<<" "<<S[i].Gm<<" ";
		cout<<S[i].Gf<<" "<<S[i].G<<endl;
	}
	return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值