PTA L1-005 考试座位号 谁还敢说用Java做不出来??

L1-005 考试座位号 (15分)

每个 PAT 考生在参加考试时都会被分配两个座位号,一个是试机座位,一个是考试座位。正常情况下,考生在入场时先得到试机座位号码,入座进入试机状态后,系统会显示该考生的考试座位号码,考试时考生需要换到考试座位就座。但有些考生迟到了,试机已经结束,他们只能拿着领到的试机座位号码求助于你,从后台查出他们的考试座位号码。

输入格式:
输入第一行给出一个正整数 N(≤1000),随后 N 行,每行给出一个考生的信息:准考证号 试机座位号 考试座位号。其中准考证号由 16 位数字组成,座位从 1 到 N 编号。输入保证每个人的准考证号都不同,并且任何时候都不会把两个人分配到同一个座位上。

考生信息之后,给出一个正整数 M(≤N),随后一行中给出 M 个待查询的试机座位号码,以空格分隔。

输出格式:
对应每个需要查询的试机座位号码,在一行中输出对应考生的准考证号和考试座位号码,中间用 1 个空格分隔。

输入样例:

4
3310120150912233 2 4
3310120150912119 4 1
3310120150912126 1 3
3310120150912002 3 2
2
3 4

输出样例:

3310120150912002 2
3310120150912119 1

首先是参考别人的做法:

L1-005 考试座位号 (15 分)[java]

import java.io.BufferedReader;
import java.io.IOException;
import java.io.InputStreamReader;
import java.util.HashMap;

public class Main {

    public static void main(String[] args) throws IOException {
        // 使用BufferReader 快速读取
        BufferedReader bReader = new BufferedReader(new InputStreamReader(System.in));
        // 读取一行中的一个整型数字
        int N = Integer.parseInt(bReader.readLine());
        HashMap<String, String[]> map = new HashMap<String, String[]>();

        while (N-- > 0) {
            // 读取一行,用空格分割
            String[] line = bReader.readLine().split(" ");
            String[] data = new String[2];
            data[0] = line[0];
            data[1] = line[2];
            // 将数据存入map
            map.put(line[1], data);
        }

        int M = Integer.parseInt(bReader.readLine());
        // 用空格分割一行中带查询的号码
        String[] query = bReader.readLine().split(" ");
        for (int i = 0; i < M; i++) {
            String[] data = map.get(query[i]);
            System.out.println(data[0] + " " + data[1]);
        }
    }
}

之后是我的做法:

import java.io.BufferedReader;
import java.io.IOException;
import java.io.InputStreamReader;
import java.util.HashMap;

public class Main {

    public static void main(String[] args) throws IOException {
        // 使用reader进行快速读取
        BufferedReader reader = new BufferedReader(new InputStreamReader(System.in));

        int n = Integer.parseInt(reader.readLine());
        String [] strings = new String[n + 1];
        String [] seats = new String[n + 1];

        int idx = 0;
        while (n-- > 0) {
            String[] s = reader.readLine().split(" ");
            idx = Integer.parseInt(s[1]);
            seats[idx] = s[2];
            strings[idx] = s[0];
        }

        n = Integer.parseInt(reader.readLine());
        String[] s = reader.readLine().split(" ");
        for (int i = 0; i < n; i++) {
            idx = Integer.parseInt(s[i]);
            System.out.println(strings[idx] + " " + seats[idx]);
        }
        reader.close();
    }
}
  • 1
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值