1067 Sort with Swap(0, i) (贪心)

1067 Sort with Swap(0, i) (贪心)

Given any permutation of the numbers {0, 1, 2,…, N−1}, it is easy to sort them in increasing order. But what if Swap(0, *) is the ONLY operation that is allowed to use? For example, to sort {4, 0, 2, 1, 3} we may apply the swap operations in the following way:

Swap(0, 1) => {4, 1, 2, 0, 3}
Swap(0, 3) => {4, 1, 2, 3, 0}
Swap(0, 4) => {0, 1, 2, 3, 4}

Now you are asked to find the minimum number of swaps need to sort the given permutation of the first N nonnegative integers.

Input Specification:

Each input file contains one test case, which gives a positive N (≤105) followed by a permutation sequence of {0, 1, …, N−1}. All the numbers in a line are separated by a space.

Output Specification:

For each case, simply print in a line the minimum number of swaps need to sort the given permutation.

Sample Input:

10
3 5 7 2 6 4 9 0 8 1

Sample Output:

9

思考:

​ 只能使用0进行交换,来使得整个序列有序,晴神宝典中给出的思路是:如果数字0当前在i位,那么就将数字i与数字0来进行交换,那么就就可以使得这个i数字有序了,同时如果0回到0号位了,那么我们就将0与循环到的第一个i!=a[i]的进行交换。

这个思路还是比较容易理解的,不过如果直接暴力循环会导致超时,看了下柳神的代码,整个代码非常的简洁,并且交换了数组的下标和值,就会使得检索的时候变得简单。

在这里插入图片描述

在这里插入图片描述

在这里插入图片描述

​ 相当于每次都是swap(a[0],a[a[0]]),直到a[0]==0,接下去就交换循环到的第一个i!=a[i]的,这就就可以继续交换,直到所有的都相等。

代码:

#include<bits/stdc++.h>
using namespace std;
int a[100005];
int main(){
	
	//ifstream cin("1.txt");
	
	int n;cin>>n;
	for(int i=0;i<n;i++){
		int t;cin>>t;
		a[t]=i;
	}
	
	int cnt=0;
	for(int i=1;i<n;i++){
	    if(i!=a[i]){
			while(a[0]!=0){
				swap(a[0],a[a[0]]);
				cnt++;
			}
		
			if(i!=a[i]){
				swap(a[0],a[i]);
				cnt++;
			}		
	    }
           	
	}
	 
	cout<<cnt<<endl; 
	

}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值