PAT 1067 Sort with Swap(0, i)(25 分)

Given any permutation of the numbers {0, 1, 2,..., N−1}, it is easy to sort them in increasing order. But what if Swap(0, *) is the ONLY operation that is allowed to use? For example, to sort {4, 0, 2, 1, 3} we may apply the swap operations in the following way:

Swap(0, 1) => {4, 1, 2, 0, 3}
Swap(0, 3) => {4, 1, 2, 3, 0}
Swap(0, 4) => {0, 1, 2, 3, 4}

Now you are asked to find the minimum number of swaps need to sort the given permutation of the first N nonnegative integers.

Input Specification:

Each input file contains one test case, which gives a positive N (≤10​5​​) followed by a permutation sequence of {0, 1, ..., N−1}. All the numbers in a line are separated by a space.

Output Specification:

For each case, simply print in a line the minimum number of swaps need to sort the given permutation.

Sample Input:

10
3 5 7 2 6 4 9 0 8 1

Sample Output:

9

程序:

#include <cstdio>
#include <algorithm>
using namespace std;
const int maxn = 100010;
int pos[maxn];
int main()
{
  int n, ans = 0;
  scanf("%d",&n);
  int left = n - 1, num;
  for(int i = 0; i < n; i++)
  {
    scanf("%d",&num);
    pos[num] = i;
    if(num == i && num != 0)
      left--;
  }
  int k = 1;//保存除0外不在本位的最小数
  while(left)
  {
    if(pos[0] == 0)
    {
      while(k < n)
      {
        if(pos[k] != k)
        {
          swap(pos[0],pos[k]);
          ans++;
          break;
        }
        k++;
      }
    }
    while(pos[0] != 0)
    {
      int temp = pos[0];
      swap(pos[0],pos[temp]);
      ans++;
      left--;
    }
  }
  printf("%d\n",ans);
  return 0;
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值