What day is that day? ZOJ-3785

It's Saturday today, what day is it after 1一次方 + 2的二平方 + 3三次方 + ... + N的N次方 days?

Input

There are multiple test cases. The first line of input contains an integer T indicating the number of test cases. For each test case:

There is only one line containing one integer N (1 <= N <= 1000000000).

Output

For each test case, output one string indicating the day of week.

Sample Input

2
1
2

Sample Output

Sunday
Thursday

Hint

A week consists of Sunday, Monday, Tuesday, Wednesday, Thursday, Friday and Saturday.

提示:这个题刚看好像确实没啥思路,不是啥算法题,嗯就是一道思维题,般思维题,都是找找规律打个表,没错,这个题就是这个思路。打表找规律。。。循环节是42。

#include<stdio.h>
//int a[55]={0,1,4,6,4,3,1,0,1,1,4,2,1,6,0,1,2,5,1,
//           5,1,0,1,4,1,4,4,6,0,1,1,3,2,6,1,0,1,2,2,1,2,6,0};
int b[55]={6,1,5,4,1,4,5,5,6,0,4,6,0,6,6,0,2,0,1,
           6,0,0,1,5,6,3,0,6,6,0,1,4,6,5,6,6,0,2,4,5,0,6,6};
int main (){
	int t;
	scanf("%d",&t);
	while(t--){
		long long n;
		scanf("%lld",&n);
		int x=n%42;
			int sum=0;
			int s=6-(n/42)%7;
			//printf("%d__%d__",s,b[x]);
		sum=(b[x]+s)%7;
		if(n%42==0) sum=(sum+1)%7;		
		if(sum==0)printf("Sunday\n");
		if(sum==1)printf("Monday\n");
		if(sum==2)printf("Tuesday\n");
		if(sum==3)printf("Wednesday\n");
		if(sum==4)printf("Thursday\n");
		if(sum==5)printf("Friday\n");
		if(sum==6)printf("Saturday\n");
	}
	return 0;
}

b数组是a数组的前缀和当然b【0】=b【42】;

  • 2
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值