PAT 1012 The Best Rank

To evaluate the performance of our first year CS majored students, we consider their grades of three courses only: C - C Programming Language, M - Mathematics (Calculus or Linear Algebra), and E - English. At the mean time, we encourage students by emphasizing on their best ranks – that is, among the four ranks with respect to the three courses and the average grade, we print the best rank for each student.

For example, The grades of C, M, E and A - Average of 4 students are given as the following:

StudentID C M E A
310101 98 85 88 90
310102 70 95 88 84
310103 82 87 94 88
310104 91 91 91 91
Then the best ranks for all the students are No.1 since the 1st one has done the best in C Programming Language, while the 2nd one in Mathematics, the 3rd one in English, and the last one in average.

Input

Each input file contains one test case. Each case starts with a line containing 2 numbers N and M (<=2000), which are the total number of students, and the number of students who would check their ranks, respectively. Then N lines follow, each contains a student ID which is a string of 6 digits, followed by the three integer grades (in the range of [0, 100]) of that student in the order of C, M and E. Then there are M lines, each containing a student ID.

Output

For each of the M students, print in one line the best rank for him/her, and the symbol of the corresponding rank, separated by a space.

The priorities of the ranking methods are ordered as A > C > M > E. Hence if there are two or more ways for a student to obtain the same best rank, output the one with the highest priority.

If a student is not on the grading list, simply output "N/A".

Sample Input

5 6
310101 98 85 88
310102 70 95 88
310103 82 87 94
310104 91 91 91
310105 85 90 90
310101
310102
310103
310104
310105
999999

Sample Output

1 C
1 M
1 E
1 A
3 A
N/A
/*
    首先给出 n 个学生 以及 m 个想要查询自己成绩的学生
    我们输出的是 每个学生 他的 最佳排名 可以是单科 也可以是 平均成绩(其实平均成绩高就代表这个学生的总分高)
    我们输出的最佳排名优先原则是 A > C > M > E
*/
#include <iostream>
using namespace std;
#include <algorithm>
#include <cmath>

struct student{
    int id;
    int grade[4]; //用数组0~3去代替 ACME 的成绩会更好啊 比单个定义好太多了
}stu[2005];

char course[4] = {'A', 'C', 'M', 'E'}; //保证优先级,最后输出时候用

int Rank[1000000][4] = {0}; //Rank[id][0] ~ rank[id][3] 为4门课对应的排名
//注意此处的Rank不能用小写字母rank来命名,似乎是sort函数内部有定义的rank结构体,因此会出现重定义的错误
int now; //cmp函数中使用,表示当前用now号分数排序stu数组
//这个now也只能定义为全局变量
bool cmp(student a, student b){
    return a.grade[now] > b.grade[now]; //分高的在前
}

int main(){
    int n, m;
    cin >> n >> m;
    for(int i=0; i<n; i++){
        cin >> stu[i].id >> stu[i].grade[1] >> stu[i].grade[2] >> stu[i].grade[3];
        stu[i].grade[0] = round((stu[i].grade[1] + stu[i].grade[2] + stu[i].grade[3]) / 3.0); //四舍五入
        
        //stu[i].grade[0] = (stu[i].grade[1] + stu[i].grade[2] + stu[i].grade[3]) / 3.0 + 0.5;
        //平均分是四舍五入的,所以需要按照+0.5后取整,保证是四舍五入的
        //平均数84.45的四舍五入不就是84,如果平均数是84.55,如果直接int得到的就是84,+0.5=85.05,int就得到85。这是一个去小数四舍五入的套路。
        //int对于小数只会向下取整的
        //stu[i].grade[0] = stu[i].grade[1] + stu[i].grade[2] + stu[i].grade[3];
        //上面说过了平均成绩高就代表这个学生的总分高 因此比较平均数相当于比较总分 也可以通过
    }
    
    for(now=0; now<4; now++){
        sort(stu, stu + n, cmp); //按照当前now号 排名
        Rank[stu[0].id][now] = 1; //每科排完名后 这一科的第一名就是 当前排过序的数组的第一个学生
        for(int j=1; j<n; j++){
            if(stu[j].grade[now] == stu[j - 1].grade[now]){ //如果当前学生的当前课程成绩等于 前一个学生的成绩
                Rank[stu[j].id][now] = Rank[stu[j - 1].id][now]; //排名相同
            }else{
                Rank[stu[j].id][now] = j + 1;
            }
        }
    }
    
    int ID; //要查询的ID
    for(int i=0; i<m; i++){
        cin >> ID;
        if(Rank[ID][0] == 0){ //如果这个ID的排名 为 0 那就是没有这个学生的成绩
            cout << "N/A" << endl;
        } 
        else{
            int min = 0; //保存4个成绩中 排名最靠前的
            for(int j=1; j<4; j++){
                if(Rank[ID][min] > Rank[ID][j]){
                    min = j;
                }
            }
     
         cout << Rank[ID][min] << " " << course[min] << endl;
        } 
    }
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值