拓扑排序入门题-CHDU-2647 - Reward (分层拓扑)

C - Reward

Dandelion's uncle is a boss of a factory. As the spring festival is coming , he wants to distribute rewards to his workers. Now he has a trouble about how to distribute the rewards. 
The workers will compare their rewards ,and some one may have demands of the distributing of rewards ,just like a's reward should more than b's.Dandelion's unclue wants to fulfill all the demands, of course ,he wants to use the least money.Every work's reward will be at least 888 , because it's a lucky number.

Input

One line with two integers n and m ,stands for the number of works and the number of demands .(n<=10000,m<=20000) 
then m lines ,each line contains two integers a and b ,stands for a's reward should be more than b's.

Output

For every case ,print the least money dandelion 's uncle needs to distribute .If it's impossible to fulfill all the works' demands ,print -1.

Sample Input

2 1
1 2
2 2
1 2
2 1

Sample Output

1777
-1

tips:注意使用longlong、

#include <iostream>
#include <algorithm>
#include <math.h>
#include <vector>
#include<cstdio>
#include <cstring>
#include <queue>
#include <map>
#include <string.h>
#include<bitset>
typedef long long ll;

using namespace std;
const int   inf=0x3f3f3f3f;
//int inf  = 2e7+100;

vector<int > v[11111],l[11111];
vector<int> ans;
map<string ,int > mp,vism;
map<int ,string>mp2;
map<string,map<string ,int > >in;

int n,m,s,num;
int   G[2222][2222];
int   vis[11111],d[1111],p[1111];

long long int topo()
{
    int cnt=0,ll=0;
    long long int sum=0;
    queue<int> cn;
    queue<int> q;
    for(int i=1;i<=n;i++)
    {
        if(vis[i]==0)
           {
               q.push(i);
               cnt++;
           }
    }
    cn.push(q.size());
    int flag1=0,flag2=0;
    while(!q.empty())
    {
        flag1++;
        int t=q.front();
        q.pop();
        for(int i=0;i<v[t].size();i++)
        {
            int k=v[t][i];
            vis[k]--;
            if(vis[k]==0)
            {
                q.push(k);
                 cnt++;
                 flag2++;
            }
        }
        if(flag1==cn.front())
        {
            cn.pop();
            sum+=flag1*ll++;
            cn.push(flag2);
            flag1=flag2=0;
        }
    }
    if(cnt==n)
        return sum+888*n;
    else
        return -1;
}


int main()
{

   while(scanf("%d%d",&n,&m)!=EOF)
   {
       for(int i=1;i<=n;i++)
         v[i].clear();
       memset(vis,0,sizeof(vis));
       for(int i=1;i<=m;i++)
       {
           int a,b;
           scanf("%d%d",&a,&b);
           v[b].push_back(a);
           vis[a]++;
       }
       long long int ans=topo();
       cout<<ans<<endl;
   }
    return 0;
}

 

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值