fzu 1752 快速幂取模+防溢出

Given A,B,C, You should quickly calculate the result of A^B mod C. (1<=A,B,C<2^63).

Input

There are multiply testcases. Each testcase, there is one line contains three integers A, B and C, separated by a single space.

Output

For each testcase, output an integer, denotes the result of A^B mod C.

Sample Input

3 2 4
2 10 1000

Sample Output

1
24

 

#include <iostream>  
using namespace std;  
#define ULL unsigned __int64  
  
ULL mul_mod (ULL a, ULL b, ULL c) //利用快速取幂模的思想求a*a%c和res*a%c,为了防止溢出  
{  
    ULL res = 0;  
    for ( ; b; b >>= 1)  
    {  
        if (b & 1)  
        {  
            res += a;    //这两句换成 res = (res + a) % c 会很慢  
            if (res >= c) res -= c;  
        }  
        a <<= 1;    //这两句换成 a = (a + a) % c 也很慢  
        if (a >= c) a -= c;  
    }  
    return res;  
}  
  
ULL qmod (ULL a, ULL b, ULL c)  
{  
    ULL res = 1;  
    for ( ; b; b >>= 1)  
    {  
        if (b & 1)  
            res = mul_mod (a, res, c);  
        a = mul_mod (a, a, c);  
    }  
    return res;  
}  
  
int main()  
{  
    ULL a, b, c;  
    while (~scanf ("%I64u%I64u%I64u", &a, &b, &c))  
        printf ("%I64u\n", qmod (a%c, b, c));  
    return 0;  
}  

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值