典型迷宫问题

/*E - 迷宫问题 */
/*定义一个二维数组:

int maze[5][5] = {

0, 1, 0, 0, 0,

0, 1, 0, 1, 0,

0, 0, 0, 0, 0,

0, 1, 1, 1, 0,

0, 0, 0, 1, 0,

};

它表示一个迷宫,其中的1表示墙壁,0表示可以走的路,只能
横着走或竖着走,不能斜着走,要求编程序找出从左上角到右下角的最短路线。
Input
一个5 × 5的二维数组,表示一个迷宫。数据保证有唯一解。
Output
左上角到右下角的最短路径,格式如样例所示。
Sample Input
0 1 0 0 0
0 1 0 1 0
0 0 0 0 0
0 1 1 1 0
0 0 0 1 0
Sample Output
(0, 0)
(1, 0)
(2, 0)
(2, 1)
(2, 2)
(2, 3)
(2, 4)
(3, 4)
(4, 4)*/

#include <iostream>
#include <stdio.h>
#include <cstring>
#include <algorithm>
using namespace std;
#define maxn 10005
int n = 5;
int vis[maxn][maxn];
struct node
{
	int x, y;//你们懂得。
	int pre;//记录前一个在队列中的位置
}q[maxn];
int dir[4][2] = { {0,-1},{0,1},{1,0},{-1,0} };
void bfs()
{
	int front = 0;//队列的首段
	int below = 1;//队列的末端()
	q[front] = { n - 1,n - 1,-1 };
	while (true)
	{
		if (q[front].x == 0 && q[front].y == 0)
		{
			while (q[front].pre != -1)
			{
				cout << "(" << q[front].x << "," << q[front].y << ")" << endl;
				front = q[front].pre;
			}
			cout << "(" << n - 1 << "," << n - 1 << ")" << endl;
			break;
		}
		for (int i = 0; i < 4; i++)
		{
			int x = q[front].x + dir[i][0];
			int y = q[front].y + dir[i][1];
			if (0 <= x && x < n && 0 <= y && y < n&&vis[x][y] == 0)
			{
				vis[x][y] = 1;
				q[below++] = { x,y,front };//将新的节点填入队列
			}
		}
		front++;//biao忘了。。
	}
}
int main()
{
	for (int i = 0; i < n; i++)
	{
		for (int j = 0; j < n; j++)
		{
			cin >> vis[i][j];
		}
	}
	bfs();
	//system("pause");
	return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值