7-7 是否同一棵二叉搜索树 (25 分)

给定一个插入序列就可以唯一确定一棵二叉搜索树。然而,一棵给定的二叉搜索树却可以由多种不同的插入序列得到。例如分别按照序列{2, 1, 3}和{2, 3, 1}插入初始为空的二叉搜索树,都得到一样的结果。于是对于输入的各种插入序列,你需要判断它们是否能生成一样的二叉搜索树。

输入格式:

输入包含若干组测试数据。每组数据的第1行给出两个正整数N (≤10)和L,分别是每个序列插入元素的个数和需要检查的序列个数。第2行给出N个以空格分隔的正整数,作为初始插入序列。最后L行,每行给出N个插入的元素,属于L个需要检查的序列。

简单起见,我们保证每个插入序列都是1到N的一个排列。当读到N为0时,标志输入结束,这组数据不要处理。

输出格式:

对每一组需要检查的序列,如果其生成的二叉搜索树跟对应的初始序列生成的一样,输出“Yes”,否则输出“No”。

输入样例:

4 2
3 1 4 2
3 4 1 2
3 2 4 1
2 1
2 1
1 2
0

输出样例:

Yes
No
No

可行思路:

暴力逐个节点匹配即可

代码样例:

#include <stdio.h>
#include <stdlib.h>

typedef struct Node *PtrToNode;
struct Node{
    int data;
    PtrToNode Left, Right;
};
typedef PtrToNode BinTree;

BinTree create(){
    BinTree p = (BinTree)malloc(sizeof(struct Node));
    p -> data = 0;
    p -> Left = p -> Right = NULL;
    return p;
}

BinTree add(BinTree bst, int x){
    if(bst == NULL){
        BinTree p = create();
        p -> data = x;
        return p;
    }
    if(x > bst -> data) bst -> Right = add(bst -> Right, x);
    else bst -> Left = add(bst -> Left, x);
    return bst;
}

int compare(BinTree a, BinTree b){
    
    if(a == NULL && b == NULL) return 1;
    if((a == NULL && b != NULL) || (a != NULL && b == NULL)) return 0;
    
    if(a->data != b->data) return 0;
    else if(!compare(a->Left, b->Left)) return 0;
    else if(!compare(a->Right, b->Right)) return 0;
    else return 1;
}

int N, L;
int main(){
    while(scanf("%d", &N)){
        if(N == 0) break;
        scanf("%d", &L);
        BinTree correctTree = NULL;
        int num = N;
        while(num--){
            int x;
            scanf("%d", &x);
            correctTree = add(correctTree, x);
        }
        //printf("1111111\n");
        BinTree checkTree = NULL;
        for(int i = 0; i < L; i++){
            checkTree = NULL;
            int m = N;
            while(m--){
                int x;
                scanf("%d", &x);
                checkTree = add(checkTree, x);
            }
            //printf("22222222\n");
            int flag = compare(correctTree, checkTree);
            if(flag) printf("Yes\n");
            else printf("No\n");
        }
    }
    return 0;
}

评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值