1002 A+B for Polynomials (25分)

This time, you are supposed to find A+B where A and B are two polynomials.

Input Specification:

Each input file contains one test case. Each case occupies 2 lines, and each line contains the information of a polynomial:

K N​1​​ a​N​1​​​​ N​2​​ a​N​2​​​​ ... N​K​​ a​N​K​​​​

where K is the number of nonzero terms in the polynomial, N​i​​ and a​N​i​​​​ (i=1,2,⋯,K) are the exponents and coefficients, respectively. It is given that 1≤K≤10,0≤N​K​​<⋯<N​2​​<N​1​​≤1000.

Output Specification:

For each test case you should output the sum of A and B in one line, with the same format as the input. Notice that there must be NO extra space at the end of each line. Please be accurate to 1 decimal place.

Sample Input:

2 1 2.4 0 3.2
2 2 1.5 1 0.5

Sample Output:

3 2 1.5 1 2.9 0 3.2

代码

#include <iostream>
#include <math.h>
#include <algorithm>
#include <stdlib.h>
#include <stdio.h>
#include <iomanip>
#include <string.h>
#include <vector>
#include <set>
#include <map>
#include <iomanip>
#include <string>
#include <sstream>

using namespace std;
map<double,double> m;
struct n
{
    double a;
    double b;
};
vector<n> ns;
bool cmp(n n1,n n2)
{
    return n1.a>=n2.a;
}
int main()
{
    int n1;
    cin>>n1;
    for(int i=0; i<n1; i++)
    {
        double x;
        double y;
        cin>>x>>y;
        m[x]+=y;
    }
    cin>>n1;
    for(int i=0; i<n1; i++)
    {
        double x;
        double y;
        cin>>x>>y;
        m[x]+=y;
    }
    for(map<double,double>::iterator it = m.begin(); it!=m.end(); it++)
    {
        n nn;
        if(it->second!=0)
        {
            nn.a=it->first;
            nn.b=it->second;
            ns.push_back(nn);
        }
    }
    cout<<ns.size();
    if(ns.size()>0)
        cout<<' ';
    sort(ns.begin(),ns.end(),cmp);
    for(int i=0; i<ns.size(); i++)
    {
        cout<<ns[i].a<<' ';
        printf("%.1lf",ns[i].b);
        if(i!=ns.size()-1)
            cout<<' ';
    }
    cout<<endl;
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值