How Many Answers Are Wrong解题报告(带权并查集)

题目

TT and FF are ... friends. Uh... very very good friends -________-b 

FF is a bad boy, he is always wooing TT to play the following game with him. This is a very humdrum game. To begin with, TT should write down a sequence of integers-_-!!(bored). 


Then, FF can choose a continuous subsequence from it(for example the subsequence from the third to the fifth integer inclusively). After that, FF will ask TT what the sum of the subsequence he chose is. The next, TT will answer FF's question. Then, FF can redo this process. In the end, FF must work out the entire sequence of integers. 

Boring~~Boring~~a very very boring game!!! TT doesn't want to play with FF at all. To punish FF, she often tells FF the wrong answers on purpose. 

The bad boy is not a fool man. FF detects some answers are incompatible. Of course, these contradictions make it difficult to calculate the sequence. 

However, TT is a nice and lovely girl. She doesn't have the heart to be hard on FF. To save time, she guarantees that the answers are all right if there is no logical mistakes indeed. 

What's more, if FF finds an answer to be wrong, he will ignore it when judging next answers. 

But there will be so many questions that poor FF can't make sure whether the current answer is right or wrong in a moment. So he decides to write a program to help him with this matter. The program will receive a series of questions from FF together with the answers FF has received from TT. The aim of this program is to find how many answers are wrong. Only by ignoring the wrong answers can FF work out the entire sequence of integers. Poor FF has no time to do this job. And now he is asking for your help~(Why asking trouble for himself~~Bad boy) 

Input

Line 1: Two integers, N and M (1 <= N <= 200000, 1 <= M <= 40000). Means TT wrote N integers and FF asked her M questions. 

Line 2..M+1: Line i+1 contains three integer: Ai, Bi and Si. Means TT answered FF that the sum from Ai to Bi is Si. It's guaranteed that 0 < Ai <= Bi <= N. 

You can assume that any sum of subsequence is fit in 32-bit integer. 

Output

A single line with a integer denotes how many answers are wrong.

Sample Input

10 5
1 10 100
7 10 28
1 3 32
4 6 41
6 6 1

Sample Output

1

本题考带权并查集,需要用到区间和递归的思想。每一个并查集都有一个跟节点,假设我们每次输入的三个数,a,b,c,用f[b]=a来表示b指向a。

时刻记住用v[a]代表a到根节点的距离,v[b]代表b到根节点的距离,t1代表a的根节点,t2代表b的根节点

一:当t1==t2时,判断是否正确

判断条件(v[b]-c是否等于v[a])

二:当t1!=t2时,把a和b的根节点连接起来

         1)t2>t1 

                          

               我们需要把a和b连起来,就是需要把a的根节点和b的根节点连起来,就是求v[t2].

               v[t2]=v[a]+c-v[b];

          2) t2<=t1

               

                  同理,我们需要连接a和b,就是把a的根节点和b的根节点连起来,就是求v[t1]。

                  v[t1]=v[b]-c-v[a]

 

具体看代码

#include <stdio.h>
#include <string.h>
#define M 200000
using namespace std;
int f[M+5],v[M+5];

void init()
{
	for(int i=0;i<=M;i++)
	{
		f[i]=i;
		v[i]=0;
	}
}

int getf(int x)    //v[x] 的值为x到跟节点的长度
{
	if(f[x]==x) return x;
	int temp=f[x];
	f[x]=getf(f[x]);
	v[x]+=v[temp];
	return f[x];
}

int main()
{
	int n,m,ans=0;
	
	while(~scanf("%d %d",&n,&m))
	{

		init();
		ans=0;
		while(m--)
	   {
		int a,b,c;
		scanf("%d %d %d",&a,&b,&c);
		a--; 
		int t1=getf(a);
		int t2=getf(b);
		if(t1==t2){
			if(v[b]-c!=v[a]) ans++;
		}
		else
		{
			if(t1<t2)
			{
				f[t2]=t1;
				v[t2]=v[a]+c-v[b];
			}
			else
			{
				f[t1]=t2;
				v[t1]=v[b]-c-v[a];
			}
		}
	 	
	    }
	    printf("%d\n",ans);
	}
	
	return 0;
}

 

  • 2
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 1
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值