ModSum

ModSum

Problem Statement

 

For an integer N, we will choose a permutation {P1,P2,…,PN} of {1,2,…,N}.

Then, for each i=1,2,…,N, let Mi be the remainder when i is divided by Pi.

Find the maximum possible value of M1+M2+[cdots]+MN.

Constraints

 

  • N is an integer satisfying 1≤N≤109.

Input

 

Input is given from Standard Input in the following format:

N

Output

 

Print the maximum possible value of M1+M2+[cdots]+MN.

Sample Input 1

 

2

Sample Output 1

 

1

When the permutation {P1,P2}={2,1} is chosen, M1+M2=1+0=1.

Sample Input 2

 

13

Sample Output 2

 

78

Sample Input 3

 

1

Sample Output 3

 

0

一个数模比他本身大的数的结果就是他本身,so,要让[1,n]分别取模[1,n]中的一个数并且使取模后的结果的和最大,那么就要使每个数取模后尽量大(一个数取模后最大也只能是本身了(笑)),所以只有1到(n-1)的数分别对2 — n取模,结果就是1到(n-1)的和,再加上n对1取模的结果,其实就是前(n-1)项的和,这样子才是最大的。

 

#include<bits/stdc++.h>

using namespace std;
int main()
{
	int n;
	while(cin >> n){
		long long ans = 0;
		for(int i = 0;i < n;i ++){
			ans += i;
		}
		cout << ans << endl;
	}
	return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值