poj 2376 Cleaning Shifts

Description

Farmer John is assigning some of his N (1 <= N <= 25,000) cows to do some cleaning chores around the barn. He always wants to have one cow working on cleaning things up and has divided the day into T shifts (1 <= T <= 1,000,000), the first being shift 1 and the last being shift T.

Each cow is only available at some interval of times during the day for work on cleaning. Any cow that is selected for cleaning duty will work for the entirety of her interval.

Your job is to help Farmer John assign some cows to shifts so that (i) every shift has at least one cow assigned to it, and (ii) as few cows as possible are involved in cleaning. If it is not possible to assign a cow to each shift, print -1.
Input

  • Line 1: Two space-separated integers: N and T

  • Lines 2…N+1: Each line contains the start and end times of the interval during which a cow can work. A cow starts work at the start time and finishes after the end time.
    Output

  • Line 1: The minimum number of cows Farmer John needs to hire or -1 if it is not possible to assign a cow to each shift.
    Sample Input

3 10
1 7
3 6
6 10
Sample Output

2

題目大意为给一个区间 给几段区间 要求 找几个区间 把这个区间包括起来
也就是贪心问题中的期区间问题。我们应该按照区间的终点排序,终点按照从小到大排序。找到终点序列终点起点为起点的值 如果没有 则返回负一 找到后,继续往候比较 如果后一个 起始点大于这个小于这个终点 咋加入。

#include <stdio.h>
#include <algorithm>
#include <utility>
const int maxn=25001;
using namespace std;
int main(){
    int N,T,k=0,pos=0 ;
    pair<int,int> cow[maxn];
    scanf("%d %d",&N,&T);
    while(N--) {
        scanf("%d %d",&cow[k].second,&cow[k].first);
        k++;
    }
    sort(cow,cow+k);
    int ans=0;
    while(pos<T){
        int id=0;
        for(int i=k-1;i>=0;i--) if(pos+1>=cow[i].second){
            pos=cow[i].first;
            cow[i].second=T+1;
            ans++;id=1;
            break;
        }
        if(!id) {ans=-1;break;}
    }
    printf("%d\n",ans);
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值