MOOC数据结构课程 题集16 Saving James Bond - Easy Version

06-图2 Saving James Bond - Easy Version (25 分)

This time let us consider the situation in the movie "Live and Let Die" in which James Bond, the world's most famous spy, was captured by a group of drug dealers. He was sent to a small piece of land at the center of a lake filled with crocodiles. There he performed the most daring action to escape -- he jumped onto the head of the nearest crocodile! Before the animal realized what was happening, James jumped again onto the next big head... Finally he reached the bank before the last crocodile could bite him (actually the stunt man was caught by the big mouth and barely escaped with his extra thick boot).

Assume that the lake is a 100 by 100 square one. Assume that the center of the lake is at (0,0) and the northeast corner at (50,50). The central island is a disk centered at (0,0) with the diameter of 15. A number of crocodiles are in the lake at various positions. Given the coordinates of each crocodile and the distance that James could jump, you must tell him whether or not he can escape.

Input Specification:

Each input file contains one test case. Each case starts with a line containing two positive integers N (≤100), the number of crocodiles, and D, the maximum distance that James could jump. Then N lines follow, each containing the (x,y) location of a crocodile. Note that no two crocodiles are staying at the same position.

Output Specification:

For each test case, print in a line "Yes" if James can escape, or "No" if not.

Sample Input 1:

14 20
25 -15
-25 28
8 49
29 15
-35 -2
5 28
27 -29
-8 -28
-20 -35
-25 -20
-13 29
-30 15
-35 40
12 12

Sample Output 1:

Yes

Sample Input 2:

4 13
-12 12
12 12
-12 -12
12 -12

Sample Output 2:

No

拯救007,听起来很吊的样子

本题完全可以不用临接表和临接矩阵,直接用一个结构体数组存储坐标,然后再用公式算两点间距离就可以了

 不过因为岛本身有宽度,所以第一跳要单独判断,之后就可以用DFS了,每次DFS都要先判断一次是否可以上岸,可以就返回

若DFS完了没有出路,说明这个图可能不是连通图,就要回到原点重新选一个点开始DFS。

#include <iostream>
#include <cmath>
#define ISLAND_WADTH 15
#define ElementType Point

typedef struct _Point
{
	int x;
	int y;
}Point;

typedef struct _GNode
{
	int Nv;
	int JP_distance;
	ElementType *point;
}Graph;

void creat_Graph(Graph *, int num_v, int num_e);
bool save007(Graph *);
bool DFS(Graph *, int start_pot, bool visited[]);
bool Is_safe(Point, int jump_distance);
bool Jump(Point start_pot, Point, int jump_distance);
bool FirstJump(Point first_pot, int jump_distance);

using namespace std;

int main()
{
	int N, D;
	cin >> N >> D;
	Graph *graph = new Graph;
	creat_Graph(graph, N, D);
	if (save007(graph))
		cout << "Yes";
	else
		cout << "No";

    return 0; 
}

void creat_Graph(Graph *graph, int num_v, int distance)
{
	graph->Nv = num_v;
	graph->JP_distance = distance;
	graph->point = new Point[num_v];
	for (int i = 0; i < num_v; i++)
		cin >> graph->point[i].x >> graph->point[i].y;
}

bool save007(Graph *graph)
{
	bool answer = 0;
	bool *visited = new bool[graph->Nv];
	for (int i = 0; i < graph->Nv; i++)
		visited[i] = 0;

	for (int i = 0; i < graph->Nv; i++)
	{
		if (visited[i] != 1 && FirstJump(graph->point[i], graph->JP_distance))
		{
			visited[i] = true;
			answer = DFS(graph, i, visited);
			if (answer) break;
		}
	}
	return answer;
}

bool DFS(Graph *graph, int start_index, bool visited[])
{
	bool answer = 0;
	visited[start_index] = 1;
	if (Is_safe(graph->point[start_index], graph->JP_distance)) answer = 1;
	for (int i = 0; i < graph->Nv; i++)
	{
		if (visited[i] != 1 && Jump(graph->point[start_index], graph->point[i], graph->JP_distance))
		{
			answer = DFS(graph, i, visited);
			if (answer) break;
		}
	}
	return answer;
}

bool FirstJump(Point first_pot, int jump_distance)
{
	if (sqrt(pow(first_pot.x, 2) + pow(first_pot.y, 2)) <= jump_distance + ISLAND_WADTH)
		return 1;
	else
		return 0;
}

bool Jump(Point start_pot, Point direction_pot, int jump_distance)
{
	if (sqrt(pow(direction_pot.x - start_pot.x, 2) + pow(direction_pot.y - start_pot.y, 2)) <= jump_distance)
		return 1;
	else
		return 0;
}

bool Is_safe(Point pot, int jump_distance)
{
	if (abs(pot.x) + jump_distance >= 50 || abs(pot.y) + jump_distance >= 50)
		return 1;
	else 
		return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值