06-图2 Saving James Bond - Easy Version (25分) (2020浙大Mooc数据结构配套题)

This time let us consider the situation in the movie “Live and Let Die” in which James Bond, the world’s most famous spy, was captured by a group of drug dealers. He was sent to a small piece of land at the center of a lake filled with crocodiles. There he performed the most daring action to escape – he jumped onto the head of the nearest crocodile! Before the animal realized what was happening, James jumped again onto the next big head… Finally he reached the bank before the last crocodile could bite him (actually the stunt man was caught by the big mouth and barely escaped with his extra thick boot).

Assume that the lake is a 100 by 100 square one. Assume that the center of the lake is at (0,0) and the northeast corner at (50,50). The central island is a disk centered at (0,0) with the diameter of 15. A number of crocodiles are in the lake at various positions. Given the coordinates of each crocodile and the distance that James could jump, you must tell him whether or not he can escape.

Input Specification:

Each input file contains one test case. Each case starts with a line containing two positive integers N (≤100), the number of crocodiles, and D, the maximum distance that James could jump. Then N lines follow, each containing the (x,y) location of a crocodile. Note that no two crocodiles are staying at the same position.

Output Specification:

For each test case, print in a line “Yes” if James can escape, or “No” if not.

Sample Input 1:

14 20
25 -15
-25 28
8 49
29 15
-35 -2
5 28
27 -29
-8 -28
-20 -35
-25 -20
-13 29
-30 15
-35 40
12 12

Sample Output 1:

Yes

Sample Input 2:

4 13
-12 12
12 12
-12 -12
12 -12

Sample Output 2:

No

  跟着小白专场一步一步写就完事了(虽然感觉第二天就会忘记了)。

代码示例:

#include<stdio.h>
#include<stdlib.h>
#include<math.h>
#define Diameter 15

typedef struct PNode *PtrToPNode;
struct PNode{
	int *x;
	int *y;
	int *visit;
	int Size;
};
typedef PtrToPNode Point;

Point ReadPoint(Point P,int N);
int Jump(Point P, int i,int n,int D);
int DFS(Point P,int n,int D); 
int Save(Point P,int D); 
int FirstJump(Point P,int D,int i); 
int IsSafe(Point P,int n,int D);

int main()
{
	int N,D,i;
	scanf("%d%d",&N,&D);
	Point P;
	P = ReadPoint(P,N);
	if(Save(P,D)) 
		printf("Yes\n");
	else
		printf("No\n");
	return 0;
} 

Point ReadPoint(Point P,int N)
{
	int i,x,y;
	/* 一开始架构出问题,懒得改干脆分配这么多动态内存好了o(* ̄▽ ̄*)ブ */
	P = (Point)malloc(sizeof(struct PNode));
	P->x = (int *)malloc(sizeof(int)*N);
	P->y = (int *)malloc(sizeof(int)*N);
	P->visit = (int *)malloc(sizeof(int)*N);
	for(i = 0; i < N; i++){
		scanf("%d%d",&x,&y);
		P->x[i] = x;
		P->y[i] = y;
		P->visit[i] = 0;
	}
	P->Size = N;
	return P;
}

int Save(Point P,int D)
{
	/*小白专场给的伪代码抄一份理解一下就行了*/
	int i,answer = 0;
	for(i = 0; i < P->Size; i++){
		if(P->visit[i] == 0 && FirstJump(P,D,i)){
			answer = DFS(P,i,D);
			if(answer == 1) break;
		}
	}
	return answer;
}

int FirstJump(Point P,int D,int i)
{
	/* 简单的勾股定理 */  
	return sqrt( pow(P->x[i],2) + pow(P->y[i],2) ) <= (D + Diameter / 2);
}

int DFS(Point P,int n,int D)
{
	//没有定义全局变量,所以传值的时候比较麻烦... 
	int i,answer = 0;
	P->visit[n] = 1;
	if ( IsSafe(P,n,D) )  answer = 1;
	for(i = 0; i < P->Size; i++){
		if(P->visit[i] == 0 && Jump(P,i,n,D)){
			answer = DFS(P,i,D);
			if(answer == 1) break;
		}
	}
	return answer;
}

int Jump(Point P, int i,int n,int D)
{
	/* 简单的勾股定理 */ 
	return sqrt( pow(P->x[n] - P->x[i],2) + pow(P->y[n] - P->y[i],2) ) <= D;
}

int IsSafe(Point P,int n,int D)
{
	int x,y;
	/* 绝对值(绝对值-50) 还小于D说明能一步上岸*/ 
	x = abs(P->x[n]) - 50;
	y = abs(P->y[n]) - 50;
	
	return (abs(x) <= D || abs(y) <= D);
	
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值