06-图2 Saving James Bond - Easy Version

This time let us consider the situation in the movie “Live and Let Die” in which James Bond, the world’s most famous spy, was captured by a group of drug dealers. He was sent to a small piece of land at the center of a lake filled with crocodiles. There he performed the most daring action to escape – he jumped onto the head of the nearest crocodile! Before the animal realized what was happening, James jumped again onto the next big head… Finally he reached the bank before the last crocodile could bite him (actually the stunt man was caught by the big mouth and barely escaped with his extra thick boot).
Assume that the lake is a 100 by 100 square one. Assume that the center of the lake is at (0,0) and the northeast corner at (50,50). The central island is a disk centered at (0,0) with the diameter of 15. A number of crocodiles are in the lake at various positions. Given the coordinates of each crocodile and the distance that James could jump, you must tell him whether or not he can escape.
Input Specification:
Each input file contains one test case. Each case starts with a line containing two positive integers N (≤100), the number of crocodiles, and D, the maximum distance that James could jump. Then N lines follow, each containing the (x,y) location of a crocodile. Note that no two crocodiles are staying at the same position.
Output Specification:
For each test case, print in a line “Yes” if James can escape, or “No” if not.
Sample Input 1:

14 20
25 -15
-25 28
8 49
29 15
-35 -2
5 28
27 -29
-8 -28
-20 -35
-25 -20
-13 29
-30 15
-35 40
12 12

Sample Output 1:

Yes

Sample Input 2:

4 13
-12 12
12 12
-12 -12
12 -12

Sample Output 2:

No
#include <stdio.h>
#include <stdlib.h>
#include <math.h>
#include <stdbool.h>

#define MaxVertexNum 100    /* 最大顶点数设为100 */
typedef int Vertex;         /* 用顶点下标表示顶点,为整型 */
typedef float DataType; 
int visited[MaxVertexNum], D, answer = 0;
        
/* 图结点的定义 */
typedef struct GNode *MGraph;
struct GNode
{
    int Nv;  /* 顶点数 */
    DataType x[MaxVertexNum]; 
    DataType y[MaxVertexNum];
};

void init(MGraph G)
{
	for(int i=0; i<G->Nv; i++) visited[i] = 0;
}

MGraph BuildGraph();
void Save007( MGraph G );

int main()
{	
	MGraph G = BuildGraph();
	init(G);
	Save007(G);
	return 0;
}

MGraph CreateGraph( int VertexNum )
{ /* 初始化一个有VertexNum个顶点但没有边的图 */
    Vertex V, W;
    MGraph Graph;     
    Graph = (MGraph)malloc(sizeof(struct GNode)); /* 建立图 */
    Graph->Nv = VertexNum;           
    return Graph; 
}

float distance(DataType x1, DataType y1, DataType x2, DataType y2)
{
	return sqrt(pow(x1-x2, 2) + pow(y1-y2, 2));
}
 
MGraph BuildGraph()
{
    MGraph Graph;
    Vertex V;
    int Nv, i;    
    scanf("%d%d", &Nv, &D);   /* 读入顶点个数及跳的最远距离 */
    Graph = CreateGraph(Nv); /* 初始化有Nv个顶点但没有边的图 */      
    for(i=0; i<Nv; i++)
    {
    	scanf("%f%f", &Graph->x[i], &Graph->y[i]);    	
	}
    return Graph;
}

bool FirstJump(DataType x, DataType y)
{
	return (D >= (distance(0, 0, x, y)-7.5));
}

bool Jump(DataType x1, DataType y1, DataType x2, DataType y2)
{
	return (D >= distance(x1, y1, x2, y2));
}

bool IsSafe(DataType x, DataType y)
{
	return ((abs(x-50)<=D)||(abs(y-50)<=D));
}

int DFS( MGraph G, Vertex V ) 
{ 
	visited[V] = 1; 	
	if( IsSafe(G->x[V], G->y[V]) ) answer = 1; 
	else
	{  
		for(Vertex W=0; W<G->Nv; W++) 
		{
			if( !visited[W] && Jump(G->x[V], G->y[V], G->x[W], G->y[W]) ) 
			{ 
				answer = DFS(G, W); 
				if(answer==1) break; 
			} 
		} 
		return answer; 
	} 
}

void Save007( MGraph G ) 
{ 
	for (Vertex V=0; V<G->Nv; V++) 
	{ 
		if(!visited[V] && FirstJump(G->x[V], G->y[V])) 
		{ 
			answer = DFS(G, V); 
			if(answer==1) break; 
		} 
	} 
	if(answer==1) printf("Yes"); 
	else printf("No"); 
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值