2016 ICPC大连赛区 [Cloned]J - Find Small A

As is known to all,the ASCII of character ‘a’ is 97. Now,find out how many character ‘a’ in a group of given numbers. Please note that the numbers here are given by 32 bits’ integers in the computer.That means,1digit represents 4 characters(one character is represented by 8 bits’ binary digits).

Input

The input contains a set of test data.The first number is one positive integer N (1≤N≤100),and then N positive integersai (1≤ ai≤2^32 - 1) follow

Output

Output one line,including an integer representing the number of ‘a’ in the group of given numbers.

Sample Input

3
97 24929 100
Sample Output

3
可以把任意一个数换成32位2进制数 如图横线上是0||1
【— — — — — — — —】【— — — — — — — —】【— — — — — — — —】【— — — — — — — —】
即判断这每个【— — — — — — — —】是否为97的二进制

#include<stdio.h>
#include<string.h>
#include<stdlib.h>
int main()
{
    int n,i,ans;
    __int64 a;
    while(~scanf("%d",&n))
    {
        ans=0;
        for(i=0;i<n;i++)
        {
            scanf("%I64d",&a);
            while(a)
            {
                if(a%256==97)
                    ans++;
                a/=256;
            }
        }
        printf("%d\n",ans);
    }
    return 0;
}
 


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值