2016大连现场赛C题 威佐夫博弈

Problem Description
Two people face two piles of stones and make a game. They take turns to take stones. As game rules, there are two different methods of taking stones: One scheme is that you can take any number of stones in any one pile while the alternative is to take the same amount of stones at the same time in two piles. In the end, the first person taking all the stones is winner.Now,giving the initial number of two stones, can you win this game if you are the first to take stones and both sides have taken the best strategy?

Input
Input contains multiple sets of test data.Each test data occupies one line,containing two non-negative integers a andb,representing the number of two stones.a and b are not more than 10^100.

Output
For each test data,output answer on one line.1 means you are the winner,otherwise output 0.

Sample Input
2 1 8 4 4 7

Sample Output
0 1 0

Source
2016ACM/ICPC亚洲区大连站-重现赛(感谢大连海事大学)

题意:全裸的威佐夫博弈if(a-b)*(sqrt(5)-1)=a则后手赢,但是输入的两个数长度长达100位

思路:

威佐夫博弈:a为a、b中较小的数,先手是否会赢 -----> (sqrt(5)+1)/2*(b-a)==a? lose:win

而对于该题,数据范围是10的100次方,还有小数乘法 ----> 黄金分割率需要精确到小数点后100位 ----> 通过二分求解。

import java.math.BigDecimal;
import java.math.BigInteger;
import java.util.Scanner;

public class Main {

    public static void main(String[] args) {

        BigDecimal sqrt5 = sqrt(new BigDecimal("5"), 120);
        BigDecimal _2 = new BigDecimal("2");
        Scanner in = new Scanner(System.in);
        BigDecimal n, m;
        while (in.hasNextBigDecimal()) {
            n = in.nextBigDecimal();
            m = in.nextBigDecimal();
            if (n.compareTo(m) < 0) {
                BigDecimal t = n;
                n = m;
                m = t;
            }
            BigDecimal k = n.subtract(m);

            n = k.multiply(BigDecimal.ONE.add(sqrt5)).divide(_2);
            BigInteger n2 = n.toBigInteger();
            BigInteger m2 = m.toBigInteger();
            System.out.println(n2.compareTo(m2) == 0 ? "0" : "1");

        }
    }
    private static BigDecimal sqrt(BigDecimal x, int n) {
        BigDecimal ans = BigDecimal.ZERO;
        BigDecimal eps = BigDecimal.ONE;
        for (int i = 0; i < n; ++i) {
            while (ans.pow(2).compareTo(x) < 0) {
                ans = ans.add(eps);
            }
            ans = ans.subtract(eps);
            eps = eps.divide(BigDecimal.TEN);
        }
        return ans;
    }
}

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值