WUST OJ HDU Problem 1002;

题目:
Description
I have a very simple problem for you. Given two integers A and B, your job is to calculate the Sum of A + B.
Input
The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line consists of two positive integers, A and B. Notice that the integers are very large, that means you should not process them by using 32-bit integer. You may assume the length of each integer will not exceed 1000.
Output
For each test case, you should output two lines. The first line is “Case #:”, # means the number of the test case. The second line is the an equation “A + B = Sum”, Sum means the result of A + B. Note there are some spaces int the equation. Output a blank line between two test cases.
Sample Input

2
1 2
112233445566778899 998877665544332211

Sample Output

Case 1:
1 + 2 = 3

Case 2:
112233445566778899 + 998877665544332211 = 1111111111111111110

解答:

#include<iostream>
#include<string>

using namespace std;

int main() {
	int T = 0;//T个用例
	int n = 1;//计数
	cin >> T;

	while (T--) {
		char A[1001] ;
		char B[1001] ;//最长1000位
		cin >> A;
		cin >> B;

		int a[1001] = { 0 };
		int b[1001] = { 0 };
		int c[1001] = { 0 };

		int A_len = strlen(A);
		int B_len = strlen(B);
		for (int i = 0; i < A_len; i++) {
			a[i] = A[A_len - 1 - i] - '0';//将字符数组A倒序给整数数组A;
		}
		for (int i = 0; i < B_len; i++) {
			b[i] = B[B_len - 1 - i] - '0';
		}

		int len_max = A_len < B_len ? B_len : A_len;

		int m = 0;//进位
		for (int i = 0; i < len_max; i++) {
			c[i] = (a[i] + b[i] + m) % 10;//进位后该位置留下的数字
			m = (a[i] + b[i] + m) / 10;//进一位的数字
		}

		cout << "Case " << n << ":" << endl;
		n++;
		cout << A << " + " << B << " = ";
		if (m != 0) {
			cout << '1';
		}
		
		for (int i = len_max - 1; i >= 0; i--) {
			cout << c[i];
		}
		cout << endl;

		if (T >= 1) {
			cout << endl;
		}
	}
	return 0;
}

注意strlen的用法,循环的时候末尾需要-1。
主要思想:用一个1001位的int型数组,将输入的数字颠倒,从末尾开始相加,然后进位。

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值