2019 多校第二场 HDU 6600

题目链接:>_>

题目:

Just Skip The Problem

Y_UME has just found a number x in his right pocket. The number is a non-negative integer ranging from 0 to 2n−1 inclusively. You want to know the exact value of this number. Y_UME has super power, and he can answer several questions at the same time. You can ask him as many questions as you want. But you must ask all questions simultaneously. In the i-th question, you give him an integer yi ranging from 0 to 2n−1 inclusively, and he will answer you if x&yi equals to yi or not. Note that each question you ask has a index number. Namely, the questions are ordered in certain aspect. Note that Y_UME answer all questions at the same time, which implies that you could not make any decision on the remaining questions you could ask according to some results of some of the questions.

You want to get the exact value of x and then minimize the number of questions you will ask. How many different methods may you use with only minimum number of questions to get the exact value of x? You should output the number of methods modulo 106+3.

Two methods differ if and only if they have different number of questions or there exsits some i satisfying that the i-th question of the first method is not equal to the i-th of the second one.

Input

There are multiple test cases.
Each case starts with a line containing one positive integer n(n≤109).

Output

For each test case, output one line containing an integer denoting the answer.

Sample Input

2

Sample Output

2

题意:

多组样例输入,每行一个n,x的范围为范围是[0,2n-1],允许你多次询问yi,然后回答你x & yi 是否等于yi,询问尽量少的次数以保证能求出xi是几,求出这样询问次数最少的询问方案数。
结果对1e6+3取模

思路:

当n=5时,询问的数y可以是1,10,100,1000,10000,所以问题最少的数量是x,题中问的是方案数,所以,进行全排列,答案为n!。

代码:

#include<bits/stdc++.h>
using namespace std;
long long a[2000010];
const int mod = 1000003;
int main() {
	long long n;
	a[1] = 1;
	for (int i = 2; i < mod; i++) {
		a[i] = a[i - 1] * i % mod;
	}
	while (~scanf("%lld", &n)) {
		if (n >= mod)printf("0\n");
		else printf("%lld\n", a[n]);
	}
	return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值