最短路dijikstra—Silver Cow Party(POJ - 3268)

题目链接:>_>

题目:Silver Cow Party

One cow from each of N farms (1 ≤ N ≤ 1000) conveniently numbered 1…N is going to attend the big cow party to be held at farm #X (1 ≤ X ≤ N). A total of M (1 ≤ M ≤ 100,000) unidirectional (one-way roads connects pairs of farms; road i requires Ti (1 ≤ Ti ≤ 100) units of time to traverse.

Each cow must walk to the party and, when the party is over, return to her farm. Each cow is lazy and thus picks an optimal route with the shortest time. A cow’s return route might be different from her original route to the party since roads are one-way.

Of all the cows, what is the longest amount of time a cow must spend walking to the party and back?

Input

Line 1: Three space-separated integers, respectively: N, M, and X
Lines 2… M+1: Line i+1 describes road i with three space-separated integers: Ai, Bi, and Ti. The described road runs from farm Ai to farm Bi, requiring Ti time units to traverse.

Output

Line 1: One integer: the maximum of time any one cow must walk.

Sample Input

4 8 2
1 2 4
1 3 2
1 4 7
2 1 1
2 3 5
3 1 2
3 4 4
4 2 3

Sample Output

10

Hint

Cow 4 proceeds directly to the party (3 units) and returns via farms 1 and 3 (7 units), for a total of 10 time units.

题意:

1~n头牛,有向图,给定一头牛的编号,其他牛要去拜访它并且拜访完之后要返回自己原来的位置,求这些牛中所花的最长的来回时间是多少。

AC代码:

#include<stdio.h>
#include<iostream>
#include<string.h>
#include<math.h>
#include<algorithm>
#include<queue>
using namespace std;
#define ll long long
#define itn int
#define maxn 0x73f3f3f
int cnt = 0,cnt2 = 0;
int head[1005],foot[1005],head2[1005],foot2[1005];
struct node {
	int to, next, w;
}x[100005],x2[100005];
void add(int start,int endd,int w) {
	x[cnt].w = w;
	x[cnt].to = endd;
	x[cnt].next = head[start];
	head[start] = cnt++;
}
void add2(int start, int endd, int w) {
	x2[cnt2].w = w;
	x2[cnt2].to = endd;
	x2[cnt2].next = head2[start];
	head2[start] = cnt2++;
}
priority_queue<node> q, Q;
bool operator <(node a,node b) {
	return a.w > b.w;
}
void init() {
	cnt = 0;
	cnt2 = 0;
	memset(head, -1, sizeof head);
	memset(head2, -1, sizeof head2);
	memset(x, 0, sizeof x);
	memset(x2, 0, sizeof x2);
	memset(foot, maxn, sizeof foot);
	memset(foot2, maxn, sizeof foot2);
	while (!q.empty())q.pop();
	while (!Q.empty())Q.pop();
}
int main() {
	int n, m, k;
	while (~scanf("%d %d %d", &n, &m, &k)) {
		init();
		itn i, j;
		int q1, q2, q3;
		for (i = 0; i < m; i++) {
			scanf("%d %d %d", &q1, &q2, &q3);
			add(q1, q2, q3);
			add2(q2, q1, q3);
		}
		node z = { k,0,0 };
		foot[k] = 0;
		q.push(z);
		while (!q.empty()) {
			z = q.top();
			q.pop();
			int start = z.to;
			for (i = head[start]; i != -1; i = x[i].next) {
				int endd = x[i].to;
				if (foot[endd] > foot[start] + x[i].w) {
					foot[endd] = foot[start] + x[i].w;
					q.push(x[i]);
				}
			}
		}
		node z2 = { k,0,0 };
		foot2[k] = 0;
		Q.push(z2);
		while (!Q.empty()) {
			z2 = Q.top();
			Q.pop();
			int start = z2.to;
			for (i = head2[start]; i != -1; i = x2[i].next) {
				int endd = x2[i].to;
				if (foot2[endd] > foot2[start] + x2[i].w) {
					foot2[endd] = foot2[start] + x2[i].w;
					Q.push(x2[i]);
				}
			}
		}
		int maxxx = 0;
		for (i = 1; i <= n; i++) {
			maxxx = max(maxxx, foot2[i] + foot[i]);
		}
		printf("%d\n", maxxx);
	}
	return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值