Dijkstra-POJ-3268-Silver Cow Party

Silver Cow Party
Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 15897 Accepted: 7238
Description

One cow from each of N farms (1 ≤ N ≤ 1000) conveniently numbered 1..N is going to attend the big cow party to be held at farm #X (1 ≤ X ≤ N). A total of M (1 ≤ M ≤ 100,000) unidirectional (one-way roads connects pairs of farms; road i requires Ti (1 ≤ Ti ≤ 100) units of time to traverse.

Each cow must walk to the party and, when the party is over, return to her farm. Each cow is lazy and thus picks an optimal route with the shortest time. A cow’s return route might be different from her original route to the party since roads are one-way.

Of all the cows, what is the longest amount of time a cow must spend walking to the party and back?

Input

Line 1: Three space-separated integers, respectively: N, M, and X
Lines 2..M+1: Line i+1 describes road i with three space-separated integers: Ai, Bi, and Ti. The described road runs from farm Ai to farm Bi, requiring Ti time units to traverse.
Output

Line 1: One integer: the maximum of time any one cow must walk.
Sample Input

4 8 2
1 2 4
1 3 2
1 4 7
2 1 1
2 3 5
3 1 2
3 4 4
4 2 3
Sample Output

10
Hint

Cow 4 proceeds directly to the party (3 units) and returns via farms 1 and 3 (7 units), for a total of 10 time units.
Source

USACO 2007 February Silver

还是用dijikstra做,不同的是要分方向,并且要同时找出双向的最短路,最后再求出所有来回路程中最大的输出。

//
//  main.cpp
//  最短路练习-D-Silver Cow Party
//
//  Created by 袁子涵 on 15/10/10.
//  Copyright (c) 2015年 袁子涵. All rights reserved.
//  63ms    8612KB

#include <iostream>
#include <string.h>
#include <math.h>
#include <algorithm>
#include <stdio.h>
#include <stdlib.h>
#define MAXN 1005
#define INF 0x7fffffff
using namespace std;
long long int N,M,X,go[MAXN],back[MAXN];
long long int cost[MAXN][MAXN];
bool vis1[MAXN],vis2[MAXN];

void Dijkstra(long long int beg)
{
    for (int i=1; i<=N; i++) {
        go[i]=back[i]=INF;
        vis1[i]=vis2[i]=0;
    }
    go[beg]=back[beg]=0;
    for (int j=1; j<=N; j++) {
        long long int k1=-1,k2=-1;
        long long int min1=INF,min2=INF;
        for (int i=1; i<=N; i++) {
            if (!vis1[i] && go[i]<min1) {
                min1=go[i];
                k1=i;
            }
            if (!vis2[i] && back[i]<min2) {
                min2=back[i];
                k2=i;
            }
        }
        if (k1==-1 && k2==-1)
            break;
        vis1[k1]=vis2[k2]=1;
        for (int i=1; i<=N; i++) {
            if (!vis1[i] && go[k1]+cost[k1][i]<go[i])
                go[i]=go[k1]+cost[k1][i];
            if (!vis2[i] && back[k2]+cost[i][k2]<back[i])
                back[i]=back[k2]+cost[i][k2];
        }
    }
}

int main(int argc, const char * argv[]) {
    cin >> N >> M >> X;
    long long int a,b,c,out=0;
    for (int i=1; i<=N; i++) {
        for (int j=1; j<=N; j++) {
            if (i==j)
                cost[i][j]=0;
            else
                cost[i][j]=INF;
        }
    }
    for (long long int i=1; i<=M; i++) {
        scanf("%lld %lld %lld",&a,&b,&c);
        cost[a][b]=c;
    }
    Dijkstra(X);
    for (int i=1; i<=N; i++)
        out=max(go[i]+back[i],out);
    cout << out << endl;
    return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值