HDU-6555-The Fool(整除分块)

The Fool

Problem Description

The Fool is numbered 0 – the number of unlimited potential –and therefore does not have a specific place in the sequence of the Tarot cards. The Fool can be placed either at the beginning of the Major Arcana or at the end. The Major Arcana is often considered as the Fool’s journey through life and as such, he is
ever present and therefore needs no number.

Given n ∈ N+, print the parity of
N
∑ [n/i],
i=1
where [x] = max a (a∈Z,a≤x)

Input

The first line of the input contains one integer T ≤ 100, denoting the number of testcases. Then T testcases follow.
In each of the T testcases, there is a positive number n ≤ 109.

Output

For each testcase, print a single line starting with “Case i : ”(i indicates the case number) and then “even” or “odd”, separated with a single space.

Sample Input

3
1
10000
100000000
 

Sample Output

Case 1: odd
Case 2: even
Case 3: even
 

Source
2018CCPC吉林赛区(重现赛)- 感谢北华大学

解题思路:

简单整除分块。对于i<sqrt(n),直接暴力。
对于i>sqrt(n)枚举 计算 等于 1-sqrt(n) 的个数。

AC代码:

#include <iostream>
#include <cstdio>
#include <math.h>
#include <algorithm>
#include <string>
using namespace std;
typedef long long ll;
const int N = 1e6+10;
struct node{
    ll i,j,k;
    ll id;
}a[N];

bool cmp(node a1,node a2)
{
    if(-a1.k*a2.i + a2.k * a1.j == -a2.k*a1.i + a1.k*a2.j)
        return a1.id < a2.id;
    return -a1.k*a2.i + a2.k * a1.j < -a2.k*a1.i + a1.k*a2.j;
}

int main()
{
    ll t,m,n;
    ll cas = 1;
    cin>>t;
    while(t--)
    {
        cin>>n;
        ll len = sqrt(n);
        ll tmp = 0;
        for(int i = 1 ; n/i >= len ; i ++)
            tmp += n/i;
        for(int i = len-1 ; i >= 1; i --)
        {
            tmp += (n/i - n/(i+1))*i;
        }
        cout<<"Case "<<cas++<<": ";
        if(tmp%2)
            cout<<"odd"<<endl;
        else
            cout<<"even"<<endl;
    }
	return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值