HDU-1908-Double Queue(STL+二分)

Double Queue

Problem Description

The new founded Balkan Investment Group Bank (BIG-Bank) opened a new office in Bucharest, equipped with a modern computing environment provided by IBM Romania, and using modern information technologies. As usual, each client of the bank is identified by a positive integer K and, upon arriving to the bank for some services, he or she receives a positive integer priority P. One of the inventions of the young managers of the bank shocked the software engineer of the serving system. They proposed to break the tradition by sometimes calling the serving desk with the lowest priority instead of that with the highest priority. Thus, the system will receive the following types of request:

Your task is to help the software engineer of the bank by writing a program to implement the requested serving policy.

Input

Each line of the input contains one of the possible requests; only the last line contains the stop-request (code 0). You may assume that when there is a request to include a new client in the list (code 1), there is no other request in the list of the same client or with the same priority. An identifier K is always less than 106, and a priority P is less than 107. The client may arrive for being served multiple times, and each time may obtain a different priority.

Output

For each request with code 2 or 3, the program has to print, in a separate line of the standard output, the identifier of the served client. If the request arrives when the waiting list is empty, then the program prints zero (0) to the output.

Sample Input

2
1 20 14
1 30 3
2
1 10 99
3
2
2
0
 

Sample Output

0
20
30
10
0
 

解题思路:

模拟题,双端队列模拟+二分,顺便复习了一下STL的deque和lower_bound()。

AC代码:

//#include <iostream>
//#include <cmath>
#include <bits/stdc++.h>
using namespace std;
typedef long long ll;
const int mod =  1e9 + 7;
const int N = 1e6+10;
struct node
{
    ll prio;
    ll id;
    node(){}
    node(ll a,ll b)
    {
        prio = b;
        id = a;
    }
    friend bool operator < (const node & a1,const node &a2)
    {
        return a1.prio > a2.prio;
    }
};
deque<node> que;

int main()
{
    int tmp;
    while(cin>>tmp && tmp)
    {
        if(tmp == 1)
        {
            ll a,b;
            cin>>a>>b;
            if(que.empty())
                que.push_back(node(a,b));
            else
            {
                deque<node>::iterator pos = lower_bound(que.begin(),que.end(),node(a,b));
                que.insert(pos,node(a,b));
            }
        }
        else if(tmp == 2)
        {
            if(que.empty())
            {
                cout<<0<<endl;
                continue;
            }
            node tmp1 = que.front();
            que.pop_front();
            cout<<tmp1.id<<endl;
        }
        else
        {
            if(que.empty())
            {
                cout<<0<<endl;
                continue;
            }
            node tmp1 = que.back();
            que.pop_back();
            cout<<tmp1.id<<endl;
        }
    }
}
  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值