hdu2161——质数判定

题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=2161

Write a program to read in a list of integers and determine whether or not each number is prime. A number, n, is prime if its only divisors are 1 and n. For this problem, the numbers 1 and 2 are not considered primes.

Input

Each input line contains a single integer. The list of integers is terminated with a number<= 0. You may assume that the input contains at most 250 numbers and each number is less than or equal to 16000.

Output

The output should consists of one line for every number, where each line first lists the problem number, followed by a colon and space, followed by "yes" or "no".

Sample Input

1
2
3
4
5
17
0

Sample Output

1: no
2: no
3: yes
4: no
5: yes
6: yes

 

题目翻译:

给一个数n,判定它是不是一个质数(要求:2和1都不是)

 

直接根据合数n的性质(能被从2到sqrt(n+0.5)内质数整除)去判断就行了,范围比较小,不需要线筛或者埃筛。

坑点(负数判断输入结束)

#include<iostream>
using namespace std;
int main(){
	int n,kcase=0;
	while(~scanf("%d",&n)){
		if(n<=0) break;
		if(n==1||n==2){
			printf("%d: no\n",++kcase);
			continue;
		}
		int flag=0;
		for(int i=2;i*i<=n;++i){
			if(n%i==0){
				flag=1;
				break;
			}
		}
		if(!flag) printf("%d: yes\n",++kcase);
		else printf("%d: no\n",++kcase);
	}
	return 0;
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值