hdu2899——函数最值问题(模拟退火)

题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=2899

Now, here is a fuction:
  F(x) = 6 * x^7+8*x^6+7*x^3+5*x^2-y*x (0 <= x <=100)
Can you find the minimum value when x is between 0 and 100.

Input

The first line of the input contains an integer T(1<=T<=100) which means the number of test cases. Then T lines follow, each line has only one real numbers Y.(0 < Y <1e10)

Output

Just the minimum value (accurate up to 4 decimal places),when x is between 0 and 100.

Sample Input

2
100
200

Sample Output

-74.4291
-178.8534

题目翻译

给定了一个函数(包含两个未知数),每次给你一个未知数的值,求这个函数的最小值。

经典的二分题,不过也可以用模拟退火去求

思路也很清楚,先随机生成一些数据,之后再对这个数据进行小修改,不断更新最小值。

跟暴力差不多,就是更强了一点,玄学过。

#include <iostream>
#include <string.h>
#include <stdlib.h>
#include <algorithm>
#include <stdio.h>
#include <time.h>
#include <math.h>
#define ITERS 10
#define T 100
#define eps 1e-8
#define delta 0.98
#define INF 1e99
using namespace std;
double x[ITERS];
int Judge(double x, double y)
{
	if(fabs(x - y) < eps) return 0;
	return x < y ? -1 : 1;
}
double Random()
{
	double x = rand() * 1.0 / RAND_MAX;
	if(rand() & 1) x *= -1;
	return x;
}
double F(double x, double y)
{
	return 6 * x * x * x * x * x * x * x + 8 * x * x * x * x * x * x + 7 * x * x * x + 5 * x * x - y * x;
}
void Init()
{
	for(int i = 0; i < ITERS; i++)
		x[i] = fabs(Random()) * 100;
}
double SA(double y)
{
	double ans = INF;
	double t = T;
	while(t > eps)
	{
		for(int i = 0; i < ITERS; i++)
		{
			double tmp = F(x[i], y);
			for(int j = 0; j < ITERS; j++)
			{
				double _x = x[i] + Random() * t;
				if(Judge(_x, 0) >= 0 && Judge(_x, 100) <= 0)
				{
					double f = F(_x, y);
					if(tmp > f) 
					    x[i] = _x;
				}
			} 
		}
		t *= delta;
	}
	for(int i = 0; i < ITERS; i++)
		ans = min(ans, F(x[i], y));
	return ans;
}
int main()
{
    int t;
	scanf("%d", &t);
	while(t--)
	{
		double y;
		scanf("%lf", &y);
		srand(time(NULL));
		Init();
		printf("%.4lf\n", SA(y));
	}
	return 0;

 

  • 1
    点赞
  • 2
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值