计算几何——TOYS(叉积判点与线的位置)

题目链接:    poj.org/problem?id=2318

Calculate the number of toys that land in each bin of a partitioned toy box.
Mom and dad have a problem - their child John never puts his toys away when he is finished playing with them. They gave John a rectangular box to put his toys in, but John is rebellious and obeys his parents by simply throwing his toys into the box. All the toys get mixed up, and it is impossible for John to find his favorite toys.

John's parents came up with the following idea. They put cardboard partitions into the box. Even if John keeps throwing his toys into the box, at least toys that get thrown into different bins stay separated. The following diagram shows a top view of an example toy box.

For this problem, you are asked to determine how many toys fall into each partition as John throws them into the toy box.

Input

The input file contains one or more problems. The first line of a problem consists of six integers, n m x1 y1 x2 y2. The number of cardboard partitions is n (0 < n <= 5000) and the number of toys is m (0 < m <= 5000). The coordinates of the upper-left corner and the lower-right corner of the box are (x1,y1) and (x2,y2), respectively. The following n lines contain two integers per line, Ui Li, indicating that the ends of the i-th cardboard partition is at the coordinates (Ui,y1) and (Li,y2). You may assume that the cardboard partitions do not intersect each other and that they are specified in sorted order from left to right. The next m lines contain two integers per line, Xj Yj specifying where the j-th toy has landed in the box. The order of the toy locations is random. You may assume that no toy will land exactly on a cardboard partition or outside the boundary of the box. The input is terminated by a line consisting of a single 0.

Output

The output for each problem will be one line for each separate bin in the toy box. For each bin, print its bin number, followed by a colon and one space, followed by the number of toys thrown into that bin. Bins are numbered from 0 (the leftmost bin) to n (the rightmost bin). Separate the output of different problems by a single blank line.

Sample Input

5 6 0 10 60 0
3 1
4 3
6 8
10 10
15 30
1 5
2 1
2 8
5 5
40 10
7 9
4 10 0 10 100 0
20 20
40 40
60 60
80 80
 5 10
15 10
25 10
35 10
45 10
55 10
65 10
75 10
85 10
95 10
0

Sample Output

0: 2
1: 1
2: 1
3: 1
4: 0
5: 1

0: 2
1: 2
2: 2
3: 2
4: 2

Hint

As the example illustrates, toys that fall on the boundary of the box are "in" the box.

题意翻译:

有一个矩形盒子,放入n块按照x轴排序的不相交的隔板,这样就将矩形盒子分成了n+1块区域。现在将m个玩具放入这个矩形盒子,统计每个区域的玩具个数。

Input

数据解释: 第一行6个整数: n(0 < n <= 5000), m (0 < m <= 5000), x1, y1, x2, y2 n代表隔板数目,m是玩具数目,x1,y1是抽屉左上角坐标,x2,y2是抽屉右下角坐标。 接下来n行给出n块板子的顶部x坐标ti,底部x坐标bi。 接下来m行给出m个玩具的坐标xi, yi。

Output

输出如样例格式的每个区间的玩具个数

模板题,对于每个区域,如果点位于上一个线段的左边和当前线段的右边,则该区域计数数组加1,之后再输出区域内的点数。

最后输出时注意一下输出格式就行了。

#include <iostream>
#include<cstring>
#include<cstdio>
using namespace std;
const int maxn=5e3+7;
struct Point{
	double x,y;
	Point(double x=0,double y=0):x(x),y(y){}
};
typedef Point Vector;
Vector operator - (Point A,Point B){
	return Vector(A.x-B.x,A.y-B.y);
} 
double Cross(Vector A,Vector B){
	return A.x*B.y-A.y*B.x;
}
bool TurnToLeft(Point a,Point b,Point c){
	if(Cross(b-a,c-b)>0) return true;
	else if(Cross(b-a,c-b)<0) return false;
}
int cnt[maxn];
pair<double,double> a[maxn];
int main(int argc, char** argv) {
	int n,m;
	double x1,y1,x2,y2;
	int flag=0;
	while(scanf("%d%d%lf%lf%lf%lf",&n,&m,&x1,&y1,&x2,&y2)&&n){
		if(flag)printf("\n");
		memset(cnt,0,sizeof(cnt));
		for(int i = 1;i<=n;i++){
			scanf("%lf%lf",&a[i].first,&a[i].second);
		}	
		a[0].first=x1;
		a[0].second=x1;
		a[n+1].first=x2;
		a[n+1].second=x2;
		
		while(m--){
			double x,y;
			scanf("%lf%lf",&x,&y);
			if(x<x1||y>y1||x>x2||y<y2) continue;
			for(int i = 1;i<=n+1;i++){
				Point r1,s1,t,r2,s2;
				r1.x=a[i-1].first;
				r1.y=y1;
				s1.x=a[i-1].second;
				s1.y=y2;
				
				
				r2.x=a[i].first;
				r2.y=y1;
				s2.x=a[i].second;
				s2.y=y2;
				
				t.x=x;
				t.y=y;
				if(!TurnToLeft(s1,r1,t)&&TurnToLeft(s2,r2,t)) cnt[i-1]++;
			}
		}
		for(int i = 0;i<=n;i++){
			printf("%d: %d\n",i,cnt[i]);
		}
		flag=1;
	}
	return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值