hdu1171-——多重背包理解

原文链接:http://acm.hdu.edu.cn/showproblem.php?pid=1171

Nowadays, we all know that Computer College is the biggest department in HDU. But, maybe you don't know that Computer College had ever been split into Computer College and Software College in 2002.
The splitting is absolutely a big event in HDU! At the same time, it is a trouble thing too. All facilities must go halves. First, all facilities are assessed, and two facilities are thought to be same if they have the same value. It is assumed that there is N (0<N<1000) kinds of facilities (different value, different kinds).

Input

Input contains multiple test cases. Each test case starts with a number N (0 < N <= 50 -- the total number of different facilities). The next N lines contain an integer V (0<V<=50 --value of facility) and an integer M (0<M<=100 --corresponding number of the facilities) each. You can assume that all V are different.
A test case starting with a negative integer terminates input and this test case is not to be processed.

Output

For each case, print one line containing two integers A and B which denote the value of Computer College and Software College will get respectively. A and B should be as equal as possible. At the same time, you should guarantee that A is not less than B.

Sample Input

2
10 1
20 1
3
10 1 
20 2
30 1
-1

Sample Output

20 10
40 40

题目翻译:

现在,我们都知道计算机学院是HDU中最大的学部。但是,也许你不知道计算机学院在2002年曾经被拆分为计算机学院和软件学院。‎
‎分裂绝对是HDU中的一件大事!同时,这也是一件麻烦的事情。所有设施必须减半。首先,对所有设施进行评估,如果两个设施具有相同的价值,则认为它们相同。假定有 N 种(0<N<1000) 类型的设施(不同值、不同类型)。‎

‎输入‎

‎输入包含多个测试用例。每个测试用例都以数字 N(0 < N <= 50 -- 不同设施点的总数量)开头。下一个 N 行包含整数 V(0_lt;V_lt;=50 -- 设施点值)和整数 M(0<M<=100 -- 相应的设施点数)。您可以假定所有 V 都不同。‎
‎以负整数开头的测试用例终止输入,并且不处理此测试用例。‎

‎输出‎

‎对于每种情况下,打印一行包含两个整数 A 和 B,分别表示计算机学院和软件学院的值。A 和 B 应尽可能相等。同时,您应该保证 A 不低于 B。‎

 

经典的多重背包题,这里取一半的总价值,然后再进行多重背包求解即为答案

#include <iostream>
#include<cstring>
using namespace std;
int n;
int v[100005],c[100005],dp[100005];
int main(int argc, char** argv) {
	while(cin>>n){
		if(n<0) break;
		int sum=0;
		memset(dp,0,sizeof(dp));
		for(int i = 1;i<=n;++i){
			scanf("%d%d",&v[i],&c[i]);
			sum += (c[i]*v[i]);
		}  
		int V=sum/2;
		for(int i = 1;i<=n;++i)
			for(int k = 0;k<=c[i];++k)
				for(int j = V;j>=v[i];--j)
						dp[j]=max(dp[j],dp[j-v[i]]+v[i]);
		printf("%d %d\n",sum-dp[V],dp[V]);
	}
	return 0;
}

 

 
  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 3
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 3
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值