hdu4738——桥(割边)

题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=4738

Caocao was defeated by Zhuge Liang and Zhou Yu in the battle of Chibi. But he wouldn't give up. Caocao's army still was not good at water battles, so he came up with another idea. He built many islands in the Changjiang river, and based on those islands, Caocao's army could easily attack Zhou Yu's troop. Caocao also built bridges connecting islands. If all islands were connected by bridges, Caocao's army could be deployed very conveniently among those islands. Zhou Yu couldn't stand with that, so he wanted to destroy some Caocao's bridges so one or more islands would be seperated from other islands. But Zhou Yu had only one bomb which was left by Zhuge Liang, so he could only destroy one bridge. Zhou Yu must send someone carrying the bomb to destroy the bridge. There might be guards on bridges. The soldier number of the bombing team couldn't be less than the guard number of a bridge, or the mission would fail. Please figure out as least how many soldiers Zhou Yu have to sent to complete the island seperating mission.

Input

There are no more than 12 test cases.

In each test case:

The first line contains two integers, N and M, meaning that there are N islands and M bridges. All the islands are numbered from 1 to N. ( 2 <= N <= 1000, 0 < M <= N 2 )

Next M lines describes M bridges. Each line contains three integers U,V and W, meaning that there is a bridge connecting island U and island V, and there are W guards on that bridge. ( U ≠ V and 0 <= W <= 10,000 )

The input ends with N = 0 and M = 0.

Output

For each test case, print the minimum soldier number Zhou Yu had to send to complete the mission. If Zhou Yu couldn't succeed any way, print -1 instead.

Sample Input

3 3
1 2 7
2 3 4
3 1 4
3 2
1 2 7
2 3 4
0 0

Sample Output

-1
4

题目翻译

曹操在赤壁战役中被诸葛亮和周瑜击败。但他不会放弃的曹操的军队还不擅长水战,所以他想出了另一个主意。他在长江上建了许多岛屿,以这些岛屿为基础,曹操的军队很容易攻击周瑜的军队。曹操还修建了连接岛屿的桥梁。如果所有岛屿都通过桥梁相连,曹操的军队就可以在这些岛屿之间部署得非常方便。周瑜受不了,所以他想摧毁一些曹操的桥梁,这样一个或多个岛屿就会与其他岛屿分开。但周瑜只有一颗原子弹是诸葛亮留下的,所以他只能摧毁一座桥。周宇必须派人携带炸弹去摧毁这座桥。桥上可能有警卫轰炸队的士兵人数不能少于一座桥的警卫人数,否则任务就会失败。请算出周瑜要派多少战士来完成海岛分岛任务。‎

‎输入‎

‎测试用例不超过 12 个。在每个测试用例中:‎

‎第一行包含两个整数,N 和 M,这意味着有 N 个孤岛和 M 桥。 ‎
‎ ‎
‎所有岛屿的编号从 1 到 N ( 2 <= N <= 1000, 0 < M <= N ‎‎2‎‎ )‎

‎下一个 M 线描述 M 网桥。每行包含三个整数 U、V 和 W,这意味着有一个连接您岛和岛屿 V 的桥,并且桥上有 W 防护装置。(U = V 和 0 <= W <= 10,000)‎
‎输入以 N = 0 和 M = 0‎
‎结束。‎

‎输出‎

‎对于每个测试用例,打印周瑜为完成任务而必须发送的最低士兵编号。如果周瑜不能成功,请改为打印-1。

 

其实就是让你求割边的个数,但是这个题有几个trick,

1、就是两点之间可能有重边

2、初始状态的图已经不是连通的了

3、某个桥就算没人守也至少派要一个人去炸桥

#include <bits/stdc++.h>
using namespace std;
const int maxn=1e3+5;
const int INF=0x3f3f3f3f;
int head[maxn],low[maxn],dfn[maxn],cut[maxn];
int n,m,total,cut_cnt,dfs_clock,union_num;
struct Edge{
	int to,nxt;
	int w;
}edge[maxn*maxn*2];
void init(){
	memset(head,-1,sizeof(head));
	memset(low,0,sizeof(low));
	memset(dfn,0,sizeof(dfn));
	dfs_clock=cut_cnt=total=0;
	union_num=1;
}
void addedge(int from,int to,int w){
	edge[total].to=to;
	edge[total].w=w;
	edge[total].nxt=head[from];
	head[from]=total++;
}
void dfs(int cur,int father){
	low[cur]=dfn[cur]=++dfs_clock;
	int pre_num=0;
	for(int i=head[cur];i!=-1;i=edge[i].nxt){
		int v=edge[i].to;
		if(v==father&&pre_num==0){
			pre_num++; 
			continue;
		}
		if(!dfn[v]){
			union_num++;
			dfs(v,cur);
			low[cur]=min(low[cur],low[v]);
			if(low[v]>dfn[cur])
				cut[cut_cnt++]=edge[i].w; 
		}
		else if(dfn[v]<dfn[cur]){
			low[cur]=min(low[cur],dfn[v]);
		}
	}
}
int main(int argc, char** argv) {
	while(~scanf("%d%d",&n,&m)&&n&&m){
		init();
		while(m--){
			int u,v,w;
			scanf("%d%d%d",&u,&v,&w);
			addedge(u,v,w);
			addedge(v,u,w);
		}
		dfs(1,1);
		if(union_num<n) printf("0\n");
		else{
			int mincost=INF;
			for(int i = 0;i<cut_cnt;++i)
				mincost=min(mincost,cut[i]);
			if(mincost==INF) mincost=-1;
			printf("%d\n",mincost==0?1:mincost);
		}
	}
	return 0;
}

 

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值