hdu3746——循环节经典变形题

题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=3746

CC always becomes very depressed at the end of this month, he has checked his credit card yesterday, without any surprise, there are only 99.9 yuan left. he is too distressed and thinking about how to tide over the last days. Being inspired by the entrepreneurial spirit of "HDU CakeMan", he wants to sell some little things to make money. Of course, this is not an easy task.

As Christmas is around the corner, Boys are busy in choosing christmas presents to send to their girlfriends. It is believed that chain bracelet is a good choice. However, Things are not always so simple, as is known to everyone, girl's fond of the colorful decoration to make bracelet appears vivid and lively, meanwhile they want to display their mature side as college students. after CC understands the girls demands, he intends to sell the chain bracelet called CharmBracelet. The CharmBracelet is made up with colorful pearls to show girls' lively, and the most important thing is that it must be connected by a cyclic chain which means the color of pearls are cyclic connected from the left to right. And the cyclic count must be more than one. If you connect the leftmost pearl and the rightmost pearl of such chain, you can make a CharmBracelet. Just like the pictrue below, this CharmBracelet's cycle is 9 and its cyclic count is 2:


Now CC has brought in some ordinary bracelet chains, he wants to buy minimum number of pearls to make CharmBracelets so that he can save more money. but when remaking the bracelet, he can only add color pearls to the left end and right end of the chain, that is to say, adding to the middle is forbidden.
CC is satisfied with his ideas and ask you for help.

Input

The first line of the input is a single integer T ( 0 < T <= 100 ) which means the number of test cases.
Each test case contains only one line describe the original ordinary chain to be remade. Each character in the string stands for one pearl and there are 26 kinds of pearls being described by 'a' ~'z' characters. The length of the string Len: ( 3 <= Len <= 100000 ).

Output

For each case, you are required to output the minimum count of pearls added to make a CharmBracelet.

Sample Input

3
aaa
abca
abcde

Sample Output

0
2
5
第一题来啦。

现在给你一个字符串,请问在该字符串末尾最少添加多少个字符,可以让这个字符串获得重复循环序列。

Input

第一行是一个整数 T ( 0<T<=100 ) 代表测试数据的组数。
之后T行每行一个字符串,由小写字母组成,字符串的长度3<=L<=100000。

Output

每组数据输出一行结果。

 

经典的循环节问题,在kmp算法中,next数组的求法和意义很妙,这类循环节的题型也算是next数组的妙用转换。

很容易知道next[i]表示s[0..i-1]中的最长前后缀长度,同理得知next[len]的含义,这里有个公式,len-next[len]=最小循环节长度,

循环节表示最长循环的子串。具体的证明如下(来自网上的大牛):

我们先假设到达位置 i-1 的时候,字符串循环了(到i-1完毕),那么如果到第i个字符的时候,失配了,
根据next数组的求法,我们是不是得回溯?
然而回溯的话,由于字符串是循环的了(这个是假定的),
next[i] 是不是指向上一个循环节的后面一个字符呢??
是的,上一个循环节的末尾是 next[i]-1 ,然后现在循环节的末尾是 i-1 ,然么循环节的长度是多少呢?
所以,我们有 (i - 1) - ( next[i] - 1 ) = i - next[i]  就是循环节的长度(假设循环成立的条件下)
现在我们已经假设了 0————i-1 循环了,那么我们就一共有i 个字符了,
如果有 i % ( i - next[i] ) == 0,总的字符数刚好是循环节的倍数,那么说明这个循环是成立的。
注意还有一点,如果 next[i] == 0,即使符合上述等式,这也不是循环的,举个反例
0   1    2   3   4   5
a    b   c   a   b   d
-1   0   0   0   1   2 
下标为1,2,3的next值均为0,那么 i%(i-next【i】)=i%i==0,但是这个并不是循环。
解释完毕,然后再来看下,为什么求出来的循环节长度是最小的呢?
因为next数组失配的时候,总是回溯到最近的循环节,所以i-next【i】就是最小的循环节长度
    为什么求出来的循环次数是最多的呢?
    循环节长度是最小的了,那么循环次数肯定是最多的了。

所以可以得出下面的结论:

如果字符串循环,那么满足两个条件:i % (i-next[i]) == 0&&next[i] != 0

循环长度= i - next[i]

循环次数= i / ( i -next[i])

 

知道上面这些就简单了,首先判断next[len]是否等于0,如果等于0,表示循环节长度为0,答案为字符串长度,之后判断len%(len-nxt[len]),如果等于0,表示没有剩余的,否则,答案就是循环节长度减去剩下的长度。

即len-next[len]-len%(len-next[len]);

#include <iostream>
#include<cstring>
using namespace std;
char str[100005];
int nxt[100005];
void getnext(){
	int len=strlen(str);
	int j=0,k=-1;
	nxt[0]=-1;
	while(j<len){
		if(k==-1||str[j]==str[k]){
			j++;
			k++;
			nxt[j]=k;
		}
		else k=nxt[k];
	}
}
int main(int argc, char** argv) {
	int T;
	cin>>T;
	while(T--){
		scanf("%s",str);
		getnext();
		int len=strlen(str);
		if(nxt[len]==0) printf("%d\n",len);
		else{
			int t=len-nxt[len];
			if(len%t==0) printf("0\n");
			else printf("%d\n",t-len%t);
		}
	}
	return 0;
}

 

 

 

  • 1
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值