poj2492——种类并查集

题目链接:http://poj.org/problem?id=2492

Background
Professor Hopper is researching the sexual behavior of a rare species of bugs. He assumes that they feature two different genders and that they only interact with bugs of the opposite gender. In his experiment, individual bugs and their interactions were easy to identify, because numbers were printed on their backs.
Problem
Given a list of bug interactions, decide whether the experiment supports his assumption of two genders with no homosexual bugs or if it contains some bug interactions that falsify it.

Input

The first line of the input contains the number of scenarios. Each scenario starts with one line giving the number of bugs (at least one, and up to 2000) and the number of interactions (up to 1000000) separated by a single space. In the following lines, each interaction is given in the form of two distinct bug numbers separated by a single space. Bugs are numbered consecutively starting from one.

Output

The output for every scenario is a line containing "Scenario #i:", where i is the number of the scenario starting at 1, followed by one line saying either "No suspicious bugs found!" if the experiment is consistent with his assumption about the bugs' sexual behavior, or "Suspicious bugs found!" if Professor Hopper's assumption is definitely wrong.

Sample Input

2
3 3
1 2
2 3
1 3
4 2
1 2
3 4

Sample Output

Scenario #1:
Suspicious bugs found!

Scenario #2:
No suspicious bugs found!

Hint

Huge input,scanf is recommended.

 

题目翻译:

Background
若雨妹妹在Debug。他惊奇的发现 Bug有两种性别,异性之间才交往,他感觉很奇怪,于是要做个实验。在他的实验中,Bug们已经被从1开始编好号了。此外,Bug的性别很好辨别。
Problem
因为若雨妹妹太懒了,他懒得去分析他总结出来的bug数据。你需要根据数据判断是否存在同性恋,输入有 t 组数据,每组数据给出bug数量n, 和关系数m, 以下m行给出相交往的一对Bug编号 a, b。只需要判断有没有,按题目要求输出。

Input

输入的第一行包含方案的数量。每个场景以一行给出,给出了由单个空格分隔的bug数(至少一个,最多2000个)和交互数(最多1000000)。在以下行中,每个交互以两个不同的bug号的形式给出,由单个空格分隔。bug从1开始连续编号。

Output

‎每个场景的输出都是一行包含"场景#i:",其中 i 是从 1 开始的场景数,然后是一行,如果实验符合他关于 Bug 性行为的假设,则有一行表示"未发现可疑 Bug!"如果霍珀教授的假设绝对是错误的,就发现了可疑的错误!‎

 

也算是带权并查集的一种:种类并查集,其实就是权值的意义不同了,其实其他的都差不多。

用r数组来表示节点与根节点的关系:0为同性,1为异性。

对每对Bug进行判断,如果属于同一个根节点,那么判断是否这一对Bug同性。

否则,进行合并和处理,处理只比普通的并查集多了一个取余的操作。

#include <iostream>
#include<cstdio>
using namespace std;
const int maxn=2e3+7;
int p[maxn],r[maxn];//r数组表示与根节点的关系,0为同性,1为异性 
int find(int x){
	int temp=p[x];
	if(p[x]!=x){
		p[x]=find(p[x]);//路径压缩 
		r[x]=(r[x]+r[temp])%2;//更新关系 
	}
	return p[x];
}
int main(int argc, char** argv) {
	int T,n,m;
	scanf("%d",&T);
	for(int kcase=1;kcase<=T;kcase++){
		int flag=1;
		scanf("%d%d",&n,&m);
		for(int i=1;i<=n;++i){
			p[i]=i;
			r[i]=0;
		} 
		while(m--){
			int x,y;
			scanf("%d%d",&x,&y);
			if(!flag) continue;
			int xx=find(x);
			int yy=find(y);
			if(xx!=yy){
				p[xx]=yy;
				r[xx]=(r[x]-r[y]+1)%2;//处理 
			}
			else{
				if((r[x]-r[y])%2==0)//同性 
					flag=0;
			}
		}
		printf("Scenario #%d:\n",kcase);
		if(!flag)
			printf("Suspicious bugs found!\n\n");
		else
			printf("No suspicious bugs found!\n\n");	 
	}
	return 0;
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值