并查集与种类并查集例题

并查集与种类并查集例题

普通并查集

How Many Tables
Today is Ignatius’ birthday. He invites a lot of friends. Now it’s dinner time. Ignatius wants to know how many tables he needs at least. You have to notice that not all the friends know each other, and all the friends do not want to stay with strangers.
One important rule for this problem is that if I tell you A knows B, and B knows C, that means A, B, C know each other, so they can stay in one table.
For example: If I tell you A knows B, B knows C, and D knows E, so A, B, C can stay in one table, and D, E have to stay in the other one. So Ignatius needs 2 tables at least.

Input
The input starts with an integer T(1<=T<=25) which indicate the number of test cases. Then T test cases follow. Each test case starts with two integers N and M(1<=N,M<=1000). N indicates the number of friends, the friends are marked from 1 to N. Then M lines follow. Each line consists of two integers A and B(A!=B), that means friend A and friend B know each other. There will be a blank line between two cases.

Output
For each test case, just output how many tables Ignatius needs at least. Do NOT print any blanks.

Sample Input

2
5 3
1 2
2 3
4 5

5 1
2 5

Sample Output

2
4

AC代码

#include <iostream>
using namespace std;
int father[1005];

void initFather(int n)
{
    for (int i = 0; i <= n; i++)
    {
        father[i] = i;
    }
}

int getFather(int person)
{
    //查找父节点
    while (person != father[person])
    {
        person = father[person];
    }
    return person;
}

//合并两个集合
void combine(int person_a, int person_b)
{
    person_a = getFather(person_a);
    person_b = getFather(person_b);
    if (person_a != person_b)
    {
        father[person_b] = person_a;
    }
}

int getResult(int n)
{
    int num = 0;
    for(int i=1;i<=n;i++)
    {
        if(father[i]==i)
            num++;
    }
    return num;
}

int main()
{
    int t;
    int personNum, dataNum;
    while (cin >> t)
    {
        while (t--)
        {
            cin >> personNum >> dataNum;
            initFather(personNum);

            int one, another;
            for (int i = 0; i < dataNum; i++)
            {
                cin >> one >> another;
                combine(one,another);
            }
            int ans = getResult(personNum);
            cout<<ans<<endl;
        }
    }
}
种类并查集

A Bug’s Life
Background
Professor Hopper is researching the sexual behavior of a rare species of bugs. He assumes that they feature two different genders and that they only interact with bugs of the opposite gender. In his experiment, individual bugs and their interactions were easy to identify, because numbers were printed on their backs.
Problem
Given a list of bug interactions, decide whether the experiment supports his assumption of two genders with no homosexual bugs or if it contains some bug interactions that falsify it.

Input
The first line of the input contains the number of scenarios. Each scenario starts with one line giving the number of bugs (at least one, and up to 2000) and the number of interactions (up to 1000000) separated by a single space. In the following lines, each interaction is given in the form of two distinct bug numbers separated by a single space. Bugs are numbered consecutively starting from one.

Output
The output for every scenario is a line containing “Scenario #i:”, where i is the number of the scenario starting at 1, followed by one line saying either “No suspicious bugs found!” if the experiment is consistent with his assumption about the bugs’ sexual behavior, or “Suspicious bugs found!” if Professor Hopper’s assumption is definitely wrong.

Sample Input

2
3 3
1 2
2 3
1 3
4 2
1 2
3 4

Sample Output

Scenario #1:
Suspicious bugs found!

Scenario #2:
No suspicious bugs found!

AC代码

#include <iostream>
#include<cstdio>
using namespace std;
int sexSet[4010];

void initSet(int bugNum)
{
    for (int i = 1; i <= bugNum * 2; i++)
        sexSet[i] = i;
}

int findRoot(int bug)
{
    if (sexSet[bug] != bug)
        sexSet[bug] = findRoot(sexSet[bug]);
    return sexSet[bug];
}

void combine(int bug_a, int bug_b)
{
    bug_a = findRoot(bug_a);
    bug_b = findRoot(bug_b);
    if (bug_a != bug_b)
        sexSet[bug_a] = bug_b;
}

int main()
{
    int t, caseNum;
    int bugNum, relationNum;
    int bug_a, bug_b;
    cin >> t;
    caseNum = 1;
    while (t--)
    {
        cin >> bugNum >> relationNum;
        initSet(bugNum);
        bool flag = true;

        for (int i = 0; i < relationNum; i++)
        {
            // cin >> bug_a >> bug_b;
            scanf("%d %d", &bug_a, &bug_b);
            if (!flag)
                continue;

            // bug_a+bugNum表示bug_a的异性
            if (findRoot(bug_a) == findRoot(bug_b) || findRoot(bug_a + bugNum) == findRoot(bug_b + bugNum))
            {
                flag = false;
                continue;
            }

            combine(bug_a, bug_b + bugNum);
            combine(bug_a + bugNum, bug_b);
        }

        cout << "Scenario #" << caseNum++ << ":" << endl;
        if (flag)
            cout << "No suspicious bugs found!" << endl
                 << endl;
        else
            cout << "Suspicious bugs found!" << endl
                 << endl;
    }
}

  • 0
    点赞
  • 2
    收藏
    觉得还不错? 一键收藏
  • 1
    评论
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值