poj 1703 Find them, Catch them——种类并查集的最简单例题

Description

The police office in Tadu City decides to say ends to the chaos, as launch actions to root up the TWO gangs in the city, Gang Dragon and Gang Snake. However, the police first needs to identify which gang a criminal belongs to. The present question is, given two criminals; do they belong to a same clan? You must give your judgment based on incomplete information. (Since the gangsters are always acting secretly.)

Assume N (N <= 10^5) criminals are currently in Tadu City, numbered from 1 to N. And of course, at least one of them belongs to Gang Dragon, and the same for Gang Snake. You will be given M (M <= 10^5) messages in sequence, which are in the following two kinds:

  1. D [a] [b]
    where [a] and [b] are the numbers of two criminals, and they belong to different gangs.

  2. A [a] [b]
    where [a] and [b] are the numbers of two criminals. This requires you to decide whether a and b belong to a same gang.

Input

The first line of the input contains a single integer T (1 <= T <= 20), the number of test cases. Then T cases follow. Each test case begins with a line with two integers N and M, followed by M lines each containing one message as described above.

Output

For each message “A [a] [b]” in each case, your program should give the judgment based on the information got before. The answers might be one of “In the same gang.”, “In different gangs.” and “Not sure yet.”
Sample Input

1
5 5
A 1 2
D 1 2
A 1 2
D 2 4
A 1 4

Sample Output

Not sure yet.
In different gangs.
In the same gang.

题目大意:

城市中有两个团伙,输入t表示例子数目,然后输入n、m,分别表示总人数和信息数。
输入A i j 表示判断i和j是不是同一伙人
输入D i j 表示i和j不是同一伙人

题目解析

错误思路
在未接触种类并查集时,我用的方法思路简单,但是是错的,如果有和我同样错误的人但还不知道为什么错的,可以看下去,否则直接看下面的正确思路吧!

  1. 我最初的想法是,如果i 和 j未指明属于哪个团队,那我就让i属于0,j属于1,这样不就分开了吗? 然后在输入一个i k,那我就让k属于(parent【i】+1)%2,也可以保证彼此是两个不同的团伙对吧!
  2. 错在哪里了呢?我们会发现,虽然我们遵循了朋友的朋友是敌人的这一基本原则,但如果输入的两个人均为分配给指定的团伙,我们怎么可以随随便便让第一个人属于0、第二个人属于1?这会对后来的信息造成影响,最后导致错误发生。
    错误代码
#include<iostream>
#include<cstdio>
#include<string>
#include<limits.h>
#include<algorithm>
#include<cstring>
#include<math.h>
#include<set>
#include<vector>
#include<queue>
#include<set>
#include<stdlib.h>
#include<time.h>
using namespace std;
typedef long long ll;
#define inf	1000000
typedef pair<int,int>	P;
const int N=100111;
int n,m;
int parent[N];
bool flag=false;
//int height[N];
void init() {
	memset(parent,-1,sizeof(parent));
	//memset(height,0,sizeof(height));
}

int find(int x) {
	if(parent[x]==-1) {
		return -1;
	} else {
		parent[x]=find(parent[x]);
	}
}


void JudgeA(int x,int y) {
	if(n<=2) {
		printf("In different gangs.\n");
		return;
	}
	if(parent[x]==-1||parent[y]==-1) {
		printf("Not sure yet.\n");
	} else if(parent[x]!=parent[y]) {
		printf("In different gangs.\n");
	} else {
		printf("In the same gang.\n");
	}

}

void JudgeD(int x,int y) {
	if(parent[x]==-1&&parent[y]==-1) {
		if(flag==false) {
			parent[x]=0;
			parent[y]=1;
			flag=true;
		}
	} else if(parent[x]==-1) {
		parent[x]=(parent[y]+1)%2;
	} else if(parent[y]==-1) {
		parent[y]=(parent[x]+1)%2;
	}
}
int main() {
	int s;
	scanf("%d",&s);

	char str[2];
	while(s--) {
		flag=false;
		init();
		scanf("%d %d",&n,&m);
		int x,y;
		while(m--) {
			scanf("%s",str);
			scanf("%d%d",&x,&y);
			if(str[0]=='A') {
				JudgeA(x,y);
			} else if(str[0]=='D') {
				JudgeD(x,y);
			}
		}
	}
	return 0;
}

正确思路:
4. 这道题就是为种类并查集而出的,而且还是最简单最基础的。两个团伙,那咱就给他开两倍数组,前一组代表朋友,后一组代表敌人,各组中每个人之间是朋友。
5. 为了所见find函数查找时间,利用height数组来辅助,高度低的树总是挂到高度高的树,这样就保证了树的高度始终保持最小。
代码:

#include<iostream>
#include<cstdio>
#include<string>
#include<limits.h>
#include<algorithm>
#include<cstring>
#include<math.h>
#include<set>
#include<vector>
#include<queue>
#include<set>
#include<stdlib.h>
#include<time.h>
using namespace std;
typedef long long ll;
#define inf	1000000
typedef pair<int,int>	P;
const int N=100000;
int parent[2*N+1];
int height[2*N+1];
int n,m;

void init(){
	for(int i=1;i<=2*N;i++){
		parent[i]=i;
		height[i]=0;
	}
}

int find(int x){
	if(parent[x]==x){
		return x;
	}else{
		return parent[x]=find(parent[x]);
	}
}

void Union(int x,int y){
	x=find(x);
	y=find(y);
	if(x==y){
		return;
	}else{
		if(height[x]<height[y]){
			parent[x]=y;
		}else if(height[y]<height[x]){
			parent[y]=x;
		}else{
			parent[x]=y;
			height[y]++;
		}
	}
}

void JudgeA(int x,int y){
	if(n==2){
		printf("In different gangs.\n");
		return;
	}
	if(find(x)==find(y)||find(x+N)==find(y+N)){
		printf("In the same gang.\n");
	}else if(find(x)==find(y+N)||find(y)==find(x+N)){
		printf("In different gangs.\n");
	}else{
		printf("Not sure yet.\n");
	}
}

void JudgeD(int x,int y){
	Union(x,y+N);
	Union(y,x+N);
}

int main() {
	int s;
	scanf("%d",&s);

	char str[2];
	while(s--) {
		init();
		scanf("%d %d",&n,&m);
		int x,y;
		while(m--) {
			scanf("%s",str);
			scanf("%d%d",&x,&y);
			if(str[0]=='A') {
				JudgeA(x,y);
			} else if(str[0]=='D') {
				JudgeD(x,y);
			}
		}
	}
	return 0;
}
  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值