HDU 3371Connect the Cities——未AC

Connect the Cities

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 25499    Accepted Submission(s): 5923


 

Problem Description

In 2100, since the sea level rise, most of the cities disappear. Though some survived cities are still connected with others, but most of them become disconnected. The government wants to build some roads to connect all of these cities again, but they don’t want to take too much money.  

 

 

Input

The first line contains the number of test cases.
Each test case starts with three integers: n, m and k. n (3 <= n <=500) stands for the number of survived cities, m (0 <= m <= 25000) stands for the number of roads you can choose to connect the cities and k (0 <= k <= 100) stands for the number of still connected cities.
To make it easy, the cities are signed from 1 to n.
Then follow m lines, each contains three integers p, q and c (0 <= c <= 1000), means it takes c to connect p and q.
Then follow k lines, each line starts with an integer t (2 <= t <= n) stands for the number of this connected cities. Then t integers follow stands for the id of these cities.

 

 

Output

For each case, output the least money you need to take, if it’s impossible, just output -1.

 

 

Sample Input

 

1 6 4 3 1 4 2 2 6 1 2 3 5 3 4 33 2 1 2 2 1 3 3 4 5 6

 

 

Sample Output

 

1

 

 

Author

dandelion

 

 

Source

HDOJ Monthly Contest – 2010.04.04

未AC代码,超出系统规定时间,样例通过,暂存,有时间优化

#include<stdio.h>
#include<algorithm>
#define MAX 501
using namespace std;
int Tree[MAX];
int findRoot(int x)
{
	if(Tree[x]==-1)
	{
		return x;
	}
	else
	{
		return findRoot(Tree[x]);
	}
}

struct Edge
{
	int a,b;
	int cost;
	bool operator<(const Edge &A) const
	{
		return cost<A.cost;
	}
}edge[MAX*MAX];

int main()
{
	int t,x,y;
	int n,m,k;
	int p[501];
	int i,j,a,b,cost;
	scanf("%d",&t);
	while(t--)
	{
		scanf("%d%d%d",&n,&m,&k);
		for(i=1;i<=n;i++)
		{
			Tree[i]=-1;
		}
		int cnt=0;
		for(i=1;i<=m;i++)
		{
			scanf("%d%d%d",&edge[cnt].a,&edge[cnt].b,&edge[cnt].cost);
			cnt++;
		}
		for(i=1;i<=k;i++)
		{
			scanf("%d",&t);
			for(j=1;j<=t;j++)
			{
				scanf("%d",&p[j]);
			}
			
			for(x=1;x<=t;x++)
			{
				for(y=1;y<=t;y++)
				{
					edge[cnt].a=p[x];
					edge[cnt].b=p[y];
					edge[cnt].cost=0;
					cnt++;
				}
			}	
		}
		sort(edge,edge+cnt);
		int sum=0;
		for(i=0;i<cnt;i++)
		{
			a=findRoot(edge[i].a);
			b=findRoot(edge[i].b);
			if(a!=b)
			{
				Tree[a]=b;
				sum+=edge[i].cost;
			}
		}
		int ans=0;
		for(i=1;i<n;i++)
		{
			if(Tree[i]==-1)
			{
				ans++;
			}
		}
		if(ans==1)
		{
			printf("%d\n",sum);
		}
		else
		{
			printf("-1\n");
		}
		
	}
	return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值