G - Lake Counting

题目描述:

Due to recent rains, water has pooled in various places in Farmer John’s field, which is represented by a rectangle of N x M (1 <= N <= 100; 1 <= M <= 100) squares. Each square contains either water (‘W’) or dry land (’.’). Farmer John would like to figure out how many ponds have formed in his field. A pond is a connected set of squares with water in them, where a square is considered adjacent to all eight of its neighbors.

Given a diagram of Farmer John’s field, determine how many ponds he has.
Input

  • Line 1: Two space-separated integers: N and M

  • Lines 2…N+1: M characters per line representing one row of Farmer John’s field. Each character is either ‘W’ or ‘.’. The characters do not have spaces between them.
    Output

  • Line 1: The number of ponds in Farmer John’s field.
    Sample Input
    10 12
    W…WW.
    .WWW…WWW
    …WW…WW.
    …WW.
    …W…
    …W…W…
    .W.W…WW.
    W.W.W…W.
    .W.W…W.
    …W…W.
    Sample Output
    3
    Hint
    OUTPUT DETAILS:

There are three ponds: one in the upper left, one in the lower left,and one along the right side.
题意:W是水,.是土地。求给出的地图中有几个池塘。注意: 斜方向的连接,也表示这两团水是连接的。
分析:这里也是一个搜索问题。我们可以遍历时如果碰到W,就立马执行dfs,并计数加1。到最后执行了几次dfs,就是几个池塘。

#include"stdio.h"
#include"string.h"
char Map[100][100];
int cont;
int n,k;
//dfs的目的是将W与之相连的W全部用. 替换
void dfs(int X,int Y)
{
    int x[8]={-1,-1,-1,0,0,1,1,1};//主意有8个方向
    int y[8]={-1,0,1,-1,1,-1,0,1};
    for(int i=0;i<8;i++)
    {
        int a=X+x[i];
        int b=Y+y[i];
        if(a>=0&&a<n&&b>=0&&b<k&&Map[a][b]=='W')
        {
            Map[a][b]='.';
            dfs(a,b);

        }
    }

}
int main()
{
    while(~scanf("%d%d",&n,&k))
    {
        for(int i=0;i<n;i++)
            scanf("%s",Map[i]);
        cont=0;
        for(int i=0;i<n;i++)
        {
           for(int j=0;j<k;j++)
           {
               if(Map[i][j]=='W')
               {
                   dfs(i,j);
                   cont++;
               }
           }
        }
      printf("%d\n",cont);
    }
}
  • 1
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值