B - Count the string(统计字符串)

题目描述:

It is well known that AekdyCoin is good at string problems as well as number theory problems. When given a string s, we can write down all the non-empty prefixes of this string. For example:
s: “abab”
The prefixes are: “a”, “ab”, “aba”, “abab”
For each prefix, we can count the times it matches in s. So we can see that prefix “a” matches twice, “ab” matches twice too, “aba” matches once, and “abab” matches once. Now you are asked to calculate the sum of the match times for all the prefixes. For “abab”, it is 2 + 2 + 1 + 1 = 6.
The answer may be very large, so output the answer mod 10007.
Input
The first line is a single integer T, indicating the number of test cases.
For each case, the first line is an integer n (1 <= n <= 200000), which is the length of string s. A line follows giving the string s. The characters in the strings are all lower-case letters.
Output
For each case, output only one number: the sum of the match times for all the prefixes of s mod 10007.
Sample Input
1
4
abab
Sample Output
6

题意:

统计每个字符串前缀在这个字符串中出现的次数。这个前缀的长度是依次增加的。
例如:样例中给出的abab
先统计a在这个字符串中出现的次数。两次。
统计ab在这个字符串出现的次数。两次。
统计aba在这个字符串出现的次数。一次。
统计abab在这个字符串出现的次数。一次。
将所有的次数加在一起,便是结果。

分析:

本题如果用暴力肯定是会超时的。所以只能借助KMP的next数组来求解。
统计next数组中大于0的个数用cnt表示。
将字符串的长度len加上cnt取余MOD便可得出正确的结论。

AC代码:

#include"stdio.h"
#include"string.h"
#define MOD 10007
void Get_next(char s1[],int next[])
{
    int i=0,j=-1,cnt=0;
    int len=strlen(s1);
    next[0]=-1;
    while(i<len)
    {
        if(j==-1||s1[i]==s1[j])
        {
            i++;j++;
            next[i]=j;
            if(next[i]>0)
                cnt++;
            cnt=cnt%MOD;
        }
        else
            j=next[j];
    }
    printf("%d\n",(cnt+len)%MOD);
}
int main()
{
    char s1[200001];
    int next[200001];
    int T,n;
    while(~scanf("%d",&T))
    {
        while(T--)
        {
            scanf("%d%s",&n,s1);
            Get_next(s1,next);
        }
    }
}
  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值