Count the string

题目描述:

It is well known that AekdyCoin is good at string problems as well as number theory problems. When given a string s, we can write down all the non-empty prefixes of this string. For example:
s: “abab”
The prefixes are: “a”, “ab”, “aba”, “abab”
For each prefix, we can count the times it matches in s. So we can see that prefix “a” matches twice, “ab” matches twice too, “aba” matches once, and “abab” matches once. Now you are asked to calculate the sum of the match times for all the prefixes. For “abab”, it is 2 + 2 + 1 + 1 = 6.
The answer may be very large, so output the answer mod 10007.

输入:

The first line is a single integer T, indicating the number of test cases.
For each case, the first line is an integer n (1 <= n <= 200000), which is the length of string s. A line follows giving the string s. The characters in the strings are all lower-case letters.

输出:

For each case, output only one number: the sum of the match times for all the prefixes of s mod 10007.

样例输入:

1
4
abab

样例输出:

6

code:

题意:给定一个字符串,找出他的所有前缀,输出这些前缀在这个字符串中出现的次数总和

#include<stdio.h>
#include<string.h>
#include<iostream>
#include<set>
using namespace std;
const int maxn=1e6+10;
const int mod=10007;
char a[maxn];
int nextt[maxn];
int n;
int sum;
void init()
{
	int i=0,j=-1;
	n=strlen(a);
	nextt[0]=-1;
	int maxx=1;
	while(i<n)
	{
		if(j==-1||a[i]==a[j])
		{
			i++;
			j++;
			nextt[i]=j;
		}
		else j=nextt[j];
	}
}
int main()
{
	int ttt;
	scanf("%d",&ttt);
	while(ttt--)
	{
		scanf("%d",&n);
		scanf("%s",a);
		init();
		sum=n;//每一个字符本身出现的次数
		for(int i=1;i<=n;i++)
		{
			int what=nextt[i];
			while(what)
			{
				sum=(sum+1)%mod;
				what=nextt[what];
			}
		}
		printf("%d\n",sum);
	}
	return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值