O - Apple Catching(dp)

题目描述:

It is a little known fact that cows love apples. Farmer John has two apple trees (which are conveniently numbered 1 and 2) in his field, each full of apples. Bessie cannot reach the apples when they are on the tree, so she must wait for them to fall. However, she must catch them in the air since the apples bruise when they hit the ground (and no one wants to eat bruised apples). Bessie is a quick eater, so an apple she does catch is eaten in just a few seconds.

Each minute, one of the two apple trees drops an apple. Bessie, having much practice, can catch an apple if she is standing under a tree from which one falls. While Bessie can walk between the two trees quickly (in much less than a minute), she can stand under only one tree at any time. Moreover, cows do not get a lot of exercise, so she is not willing to walk back and forth between the trees endlessly (and thus misses some apples).

Apples fall (one each minute) for T (1 <= T <= 1,000) minutes. Bessie is willing to walk back and forth at most W (1 <= W <= 30) times. Given which tree will drop an apple each minute, determine the maximum number of apples which Bessie can catch. Bessie starts at tree 1.
Input

  • Line 1: Two space separated integers: T and W

  • Lines 2…T+1: 1 or 2: the tree that will drop an apple each minute.
    Output

  • Line 1: The maximum number of apples Bessie can catch without walking more than W times.
    Sample Input
    7 2
    2
    1
    1
    2
    2
    1
    1
    Sample Output
    6
    Hint
    INPUT DETAILS:

Seven apples fall - one from tree 2, then two in a row from tree 1, then two in a row from tree 2, then two in a row from tree 1. Bessie is willing to walk from one tree to the other twice.

OUTPUT DETAILS:

Bessie can catch six apples by staying under tree 1 until the first two have dropped, then moving to tree 2 for the next two, then returning back to tree 1 for the final two.

分析:

本来是不想写这篇博客的。 但是看了一下网上的其他题解。发现方法都和我的不一样。
其他方法的定义状态都是 i代表秒数, j代表移动次数。
而我是i 代表移动次数, j代表秒数。
dp[i][j]表示移动了i次在j秒处的能接到的最大苹果数。
那么状态转移方程就为:
在这里插入图片描述
因为移动了奇数次和移动了偶数次 他在这一次能接到了苹果树是不同的。 所以需要区分开来。
移动了奇数次,那么他就只能接2号树下的苹果。
移动了偶数次,那么他就只能接1号树下的苹果。
他在i次移动后 j 秒的时候,能不能接这个苹果取决于这个苹果是哪颗树上的苹果。
AC代码:

#include"stdio.h"
#include"string.h"
#include"algorithm"
using namespace std;
int main()
{
    int T,W;
    int dp[32][1010];
    memset(dp,0,sizeof(dp));
    int a[1010];
    scanf("%d%d",&T,&W);
    for(int i=1; i<=T; i++)
    {
        scanf("%d",&a[i]);
    }
    dp[0][0]=0;
    for(int i=1; i<=T; i++)//一次都不移动的初始化状态
        dp[0][i]=dp[0][i-1]+(1==a[i]);
    for(int i=1; i<=W; i++)
    {
        for(int j=1; j<=T; j++)
        {
            if(i%2==1)
            {
                dp[i][j]=max(dp[i-1][j]+(2==a[j]),dp[i][j-1]+(2==a[j]));
            }
            else
                dp[i][j]=max(dp[i-1][j]+(1==a[j]),dp[i][j-1]+(1==a[j]));
        }
    }
    printf("%d\n",dp[W][T]);
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值